Metadata categories won't delete

i tried to delete a few custom metadata categories that i created and they won’t delete. i went to data in preferences, then in the list of custom metadata on the left i just clicked the remove button (minus sign) but they keep reappearing.

Are you syncing files from another Mac running DEVONthink 3 that have this metadata applied to them?


When do they keep reappearing?

When using the Info Inspector: Custom ?

When returning to Preferences > Data

After quitting and relaunching DEVONthink?

when returning to preferences - data and after quitting and relaunching, yes. NOT when using the info inspector.

Please send the file ~/Library/Application Support/DEVONthink 3/CustomMetaData.plist to cgrunenberg - at - - thanks! In addition, which definition did you try to remove?

yup, sent!

The below-mentioned quick and dirty fix works for me in DT3b2, but your issue may be different. You want to try this while waiting for DT to check what happened.

(1) change the sticky custom field to a different data type.
(2) use batch processing to empty the content of the sticky custom data field for all items.
(3) delete the field again.

I didn’t receive the file so far, did you send it to my email address or to support?

hi, i believe i sent this to your email address. (sorry for delay in responding.) this is still happening - i will delete metadata categories, but they immediately show back up again. i’ve tried clearing them, but nothing works.

Could you please send me the file again? Thanks!

sent! thanks.