Missing multiple folders/documents in DevonThink 3.7.2

Ok, so what you are describing obviously should not be happening; I currently have no explanation for why it is happening. To further test what is happening, I would

  • try to move just one record from the backup database to the new database
    • does that work, or does the single file also end up in system trash?

Possible solutions could be:

  • use duplicate rather than dragging and dropping the group (so select the group, then from the context menu select duplicate to yournewdatabase)
  • use the export function to export the group, then reimport it to the new database

A question or two:

  • where are your databases located; specifically: are they on the internal drive in your Mac, or on an external drive, NAS oder even in the cloud?
  • is there enough space left on the drive?
  • do you have antivirus software running which might be interfering with the copy process?
  • do you have any other software which monitors folders and performs actions (such as Hazel, for example)?
  • Do the files appear even briefly in the new database when you move them, or do they appear to go straight to system trash?
1 Like

Yes, that works. The group I have tried to move before was UNDER the main database name. I can confirm there is no issue to move any subgroup.

Working :slight_smile:

All database are on my Mac drive.

More than 2TB

NO

NO I don’t.

straight to the trash.

Thanks for all that; if you can be bothered to experiment, you could

  • remove all content from the group, then move it
    • does it move, or does it got to trash?
      • if it goes to trash: what is the name of the group? Does it have any obvious defining characteristics?
      • if it moves, then repeat the same after removing just half the content
        • if that works, try with the other half

What I’m trying to figure is, is this something to do with the group, it’s size or it’s contents. Obviously, if duplicating works for you, then your problem is solved; so any further effort you put in would be for the community, potentially saving somebody else from the same problem. Thanks :slight_smile:

Move - no problem without any contents.

I have removed half of the content - the group moved by dragging without any problems.

Other half works as well by dragging,.

Thanks so much for trying this; so at least on a basic level that suggests that the quantity or size of the content is the problem, not the content itself.

@yoda, for sake of being thorough (so perhaps I might be able to set up a couple of test databases and see whether I can reproduce what you have seen): you mentioned 1700 items; what is the total size of those items approximately? Is your disk formatted APFS or HFS? Are the databases encrypted or not?

@BLUEFROG, @cgrunenberg Dear Jim & Criss, I don’t think I can be of any further help in diagnosing whether this is a bug and what the cause might be. I hope the feedback which @yoda has so kindly provided might help you in pinpointing a possible cause or at least make for follow-up questions.

And if you go back to the original action, moving the entire folder with all its contents, does the issue recur?

Group is 1.2G 1773 items
HD is APFS
no database encryption.

Thank you for your help :+1:t2:

I can confirm this is still happening

And this is dragging the group from one database to another inside DEVONthink, correct?

What smart rules are installed?

none, apparently

Well there are three installed by default, including the Filter Duplicates smart rule. So he may not be using them, but may have some still active. :slight_smile:

just like to keep you on your toes :smiley: or is it you keeping me on your toes? :ghost:

Both, depending on the moment :slight_smile:

1 Like

Just happen again… move a group of 2736 items / 967.3M by right click move to another database… group has vanish from the source and nothing got to the destination database. this time nothing in the trash (system or DT)

I should have use duplicate I know… just thinking a new database (both) it should work.
I find it as a bug in this release as in past I have never got a problem to move a lot of items.

TY

A screenshot of all your smart rules would be useful. In addition, is there enough disk space available? Do you use any encrypted databases?

No smart rules.
more that 1T available
no encryption

After further investigation, its looks like the items actually moved (database size has increased + items counts) but the group + all subgroups that I have moved does not show in the database.
Just to emphasis , it is a new database!! no other items.
I can conform repeating the same action again (new database, new group) give the same results.

Did you try to find the moved items in the new database via the search and to reveal them?

No I didn’t as finding the items itself is not relevant to me, I need all the group structure not just the files.

Even without the groups it would be useful to know where the items are now.