Moved Files Lose Content

I run DTPO 2.x on a MBPro with Snow Leopard 10.6.5. I have recently noticed that at unpredictable times, when I move a document from one folder or a database to another, the file will show up in the new location, but then when I click on it, it gives me a blank page with “No Selection.” It seems that it is getting worse.

I sometimes quickly scan information in from my ScanSnap to my global inbox, then maybe tag it, maybe not, and leave it there for a few days while I’m busy with higher priority things than filing. When I come back to file the doc away in the intended database all is still well in the global inbox. I open up the database that I want to move it into, and then drag and drop it in. The thumbnail for the doc shows, but the content is empty. I’ve had it happen that the thumbnail (agonizingly) shows the content of the document, but the file shows up blank and might as well be dead to me.

A few times I’ve been lucky: I’ve used HoudahSpot to find the file if I’ve, say, attached it to an email and sent it out, and HoudahSpot finds it in Mail’s library cache. But if I’ve tossed the original document and can’t find the document through HoudahSpot, I’m screwed. It’s gone. Or, more accurately, it’s there, but empty. A .pdf reader like Preview or Acrobat will give me an error message and tell me that the file is empty.

The bottom line is this: right now, I can’t trust DEVONthink Pro Office not to lose my data when I move document among my databases (and I’ve had this problem occur when moving docs within a single database, from one folder to another) And if that’s the case, why did I pay top dollar for DTPO?

Addendum: I should add that I keep all my DTPO databases on my Dropbox account, because it syncs virtually instantly and I have multiple devices.

It’s definitely not recommended to share/sync open DTPO databases with Dropbox, per the FAQ item and many topics discussing this issue (see search results for dropbox). If that’s what you’re doing it seems likely the source of your problem.

Am I to assume this is true of putting DTPO databases on a server as well?

I’m sorry, but that’s not really acceptable in the age of cloud computing. I have two computers, an iPhone, and probably an iPad soon. I need access to my data, no mater what machine I’m on. If DTPO was intended as an office-grade document database system, then having a solution that is chained to a single machine is obviously inadequate, no matter how many bells and whistle you spackle onto it.

So when can we expect this situation to change? I spent a lot of money on DTPO, but will migrate to something else if there are no plans to change the status quo.

The important point is that DEVONthink databases are single-user, and attempts to access an open database from more than one copy of a DEVONthink application are emphatically not recommended.

Some users use DropBox to enable access to a database from more than one of their computers. If you search the forum for discussions about DropBox use, you will find precautions that, if followed, will mitigate problems that might otherwise occur.

One of the most important precautions is to close all open databases on the last-used computer, before accessing them from a different computer (that applies to running databases off a server, as well).

DEVONtechnologies expects to introduce a Synch procedure in 2011 for DEVONthink databases. This will allow sync via local or remote networks, including MobieMe.

The DEVONthink To Go app allows one to sync selected contents of DEVONthink databases on a Mac by replicating them to a Sync group, then initiating sync to a mobile device such as an iPad and/or iPhone or iPod Touch.

Bill, Thank you! That is actually what I do. I’m very careful to close out databases before leaving whatever computer I’m working on. And DTPO is very good about warning me if I forget and then try to open the database from another computer. So I’m relieved to hear this, and also excited about a more robust sync solution in the future.
Incidentally, I would not have thought that storing DTPO databases on MobileMe, or any WebDAV solution, would have been advisable, since changes in the database, say when you’re doing a recursive download of email, can happen while the WebDAV site is trying to sync. I really screwed up my MobileMe account two years ago, when I added my 1Password account to it. When I downloaded information en masse, my My Disk account broke, basically, and it took MONTHS to get it to work right again. I stored both my 1Password database and all my DTPO databases on Dropbox, simply because the sync is faster.

However, I’m not convinced that using Dropbox is responsible for my documents being stripped of their contents when I move them within groups of a single database. I think I’ll make duplicates before moving anything from now on, so go ahead and mark this “answered,” but you may want to bring this problem to the attention of your elves, particularly if their working on the projected sync solution you mention.

Best, Erik

I have been encountering the same problem and, heres the kicker, I am not storing files on Dropbox. Currently using 10.6.5 and DevonThink Pro Office 2.0.6.

Files seem to import normally and upon move between databases (eg global inbox to a Devonthink database file) become corrupted.

This goes to trust in the system and is a BIG problem for my continued use of Devonthink.

Any thoughts ???


The problem I have is that, once moved, the files show up, even with thumbnail, but when I click on them I get a message along the lines of “This File Has No Content,” or something like that. Does this describe your situation?

Dear DT team,

I encountered this serious bug as well.

And NO, I dont have my database stored on Dropbox. Still, this problem happens: I had set up a rule in Hazel that moves files to the “inbox” folder for automatic import. As a result, I had many imported files, but there are also other files that were not imported.

Devon Think reported an error in the log for those files (simply states “failed”).

I looked at the files that were still left in the inbox folder. They still had their original size displayed in the Finder, but were irrevocably lost. Couldnt open them, anything. for example said the image could not be opened because the file is empty.

Thanks Apple for Time Machine…

So yeah, Devon Think has some data loss issue. PLEASE guys fix this, I just started to understand and love the app and now this severe bug :frowning:


Pretty much summs it up. Have been taking a closer look at Evernote. I can’t accept lost data and I am loosing trust in Devonthink.

I just tried the import once more, but the problem persists.

Files to be imported become completely unreadable!

This is really bad… I hope it gets fixed with top priority. Dont know how to use this program if I cant trust that it wont kill my files :frowning:

Back to the Time Machine…

As a suggestion, try running your workflow in steps to ensure that the problem occurs during the import and not during the execution of the Hazel. That is, quit DEVONthink so that it is not part of the equation during step #1. Run the same Hazel rule to move the documents to the Global Inbox and then check to see if those documents are still intact, also checking the modification date/time of the documents. Step #2 would be to launch DEVONthink to initiate the actual import of the Inbox folder to the Inbox.dtBase2 and see what happens. If some of the documents do not import, check to see if the modification date/time of the documents has changed to the time when the import was initiated.

It’s also possible there is a directory or permissions problem on your disk. Consider launching OS X’s Disk Utility (boot from the OS install disk or a clone of your system drive, if you have a clone) and using Repair Disk and Repair Disk Permissions.

I followed your instructions.
Hazel successfully copied all files to the Inbox folder as the rules stated. I checked them all.
THEN I stopped Hazel to avoid any interference.
I opened DevonThink and it imported the files. Then came the error messages once again. Interestingly, I found a pattern: JPGs for example were imported with the error, displaying “failed” in the log window. However, .webarchive files were also imported, and the import failed, but this failure was not displayed in the log. Weird!

Also, the files that were corrupted had no change in their modification date.

I repaired the permissions just recently, dont think it is caused by this. Repeated it though, no folders concerning DevonThink were listed.

I have tried DT import several times by now, always keeping some kind of backup in case something happens.

Most interestingly: I didnt run into any errors anymore.

It may be related to one or more of the following things that I have changed since the problems occured:

  • I disabled “Clusters”, a preference pane that compresses files (including those to be imported) with Snow Leopards included compression method

  • I always quit DevonThink and dont put the computer to sleep while having it open. May be related.

Can anyone chime in if Clusters is open on their computers? Or if it may be a quit/sleep related issue? :question:

It’s the second report related to Clusters and therefore we definitely discourage usage of this “extension” for now.

The only other known case which might damage/corrupt files are disk images running out of free space.