Moving Devonthink to a new computer Mac

If you plan to use Migration Assistant, be sure both computers are running the same version of macOS. On my first try, my old MacBook Pro was running an older version and it did not go well. I used peer-to-peer rather than WI-FI transfer.

2 Likes

Regarding global smart rules and groups being synced with the inbox, I just checked. A global smart group or rule created on one machine doesn’t appear on another machine when you sync it.

You can, however, right click a smart group or rule and export it. If I understand correctly, that doesn’t export the contents of the group or rule, just the group or rule itself.

You can also export a multiple selection.

The group is imported on another machine by double clicking on it in the Finder. Export to a thumb drive on one machine, import on another with a double-click.

That is correct. Global smart groups, smart rules, Favorites, and application preferences do not sync between machines at this time.

No worries!
We just refer to them as indexed items or files.

Following up on @rmschne’s comment: Put the indexed files back in the same relative place on the new Mac. For example, if you were indexing a folder called Stuff in your Documents folder, make sure you transfer that Stuff folder to the Documents folder in the new machine.

1 Like

Another vote for the Mac OS Migration Assistant (and Time Machine backups)

My MacMini died last week; leaving me with a 10 year old Apple Time Capsule and my iCloud database backups

I plugged in the new machine, and Migration Assistant kicked in; loading the DT app, files and databases. The iCloud database backups weren’t required
With little effort on my part, I’m up and running

Internal storage is limited so I moved the databases to an external drive
(new addition for my Time Machine backups)

3 Likes

Thanks. That gives me hope. I’m doing a preventive replacement while my 4 year old MacMini hard drive is still healthy. The new one is all SSD and I hope to get longer life out of it. I lived through a hard drive failure with corrupt backup file WAY BACK in the DOS days - never want to go through that again.

@rmschne and @BLUEFROG have provided a lot lot of information about specific settings and content that do not transfer with sync in DT3. I’m not syncing at the present time. Since I’m planning on moving forward with Apple’s Migration Assistant, restoring from TimeMachine, I’m figuring I won’t need to worry about DT3 elements that don’t migrate with sync. But I will make notes of the current settings so I can check/confirm on the transfer. Sounds like I will be able to go back to DT3 on my old machine and export if necessary.

Just an update on this item. I finished the migration of my TimeMachine backup to my new MacMini yesterday - and it took most of the day - since I just put everything on the new machine like it was on the old one.

I opted to keep my existing TimeMachine history files (back to Feb. 2019 - I’m such a pack-rat), rather than starting a new version for the new machine. I just made sure to close all my files before shutting down the old machine. Then plugged all my devices into the new MacMini and started it up. The migration assistant worked well, though it took a bit over 3 hours to restore (about 650 GB of files) from my external TimeMachine drive.

I was unable to use TimeMachine on the new MacMini until I got the drive’s encryption password logged into the new Mac’s keychain. And toward the end of the install got a warning message that System Extensions were not enabled (I don’t know what that means - so I just clicked “Not Now”)

I had no issues with DT3 databases, including an encrypted one and one that contains a 30k index of files and folders on my hard drive. And just like @BLUEFROG noted, I was able to run DT3 until I was able to delete my old mac mini and register my new one. The only significant issues I had were; I had to restart a couple of times because my encrypted TimeMachine drive was not recognized after the install; the need to repeatedly log in with my Apple ID to connect to iCloud; and my MS 365 personal, Excel failed to restore properly which required a 2 hour call with MS. Before I contacted MS I tried to reinstall Excel but got the browser message that there was not sufficient space on my hard drive to download the MS package (even though Finder showed I have over 600 GB left on the 1TB SSD - but MS support was able to resolve it.

2 Likes

Glad to hear it - and indeed a full transition can be a day-long adventure! :slight_smile:

dear Jim, do you remember my feature suggestion from may 2019: