Multiple problems with DTPO2 installation

I’m having numerous problems since upgrading from DTPO1 to 2:

  1. the upgrade did not seem to install correctly such that preferences screen will not open.
  2. DTPO cannot be uninstalled completely (I throw it in the trash, but the sorter app keeps running and who knows what else.)
    2.5) Because DTPO doesn’t completely uninstall, when I try to install the latest version it will trash the old DTPO app, but I get the errors "
  3. the sorter app does not appear as an app that can be stopped by calling Cmd_opt_esc.
  4. now DTPO2 won’t even launch. Instead it turns into a pumpkin (it’s icon morphs into a generic app icon when clicked and no app starts).

These troubles are present when logged in as administrator (my account) and as guest.

How can I ditch the current version completely including the sorter and have this reinstall correctly? I have posted the console contents here before and can again if that would be helpful. I suspect some file system problems (permissions?), though I’ve corrected them when I’ve found them.

Any help is appreciated as I use DTPO for everything!

The Sorter will appear in Activity Monitor, so you can quit the app there. I know because I’ve done it. The other details, I can’t really help you with.

The Sorter can also be quit by clicking to open it. Click on the action button (cogwheel symbol) near the bottom left and choose Hide.

I’m going to suggest the brute force method here.

***Warning: Be sure to back up all your DTPO1 and DTPO2 databases, preferably to a CD or DVD! ***

  1. Use your browser to find Version Tracker and then search for “App Zapper.” Download it and keep it handy.

  2. Restart your mac in “safe” mode by holding down the shift key when rebooting.

  3. You’ll notice that nothing (or a very few things) load when you log in.

  4. Locate App Zapper and launch it.

  5. Drag the icon of DTPO (the app) onto the target area of App Zapper. You’ll see a list of DTPO and related files.

  6. Zap them all!

  7. Empty the Trash (force empty if needed - hold down the alt key when selecting “Empty Trash”)

  8. Reboot

  9. Download DTPO2 again - go to this page and select the first download item (DTPO 2 beta 4)

  10. Reinstall and hopefully things will be better.

  11. Reboot

I think I need the brute force method. I have app zapper and will use it once the databases are in a safe place.

On my system the activity monitor did not display the sorter, nor was it present on the screen. (although in previous weeks it was visible on the screen, but the cogwheel did not do anything when clicked).

I verified the system disk and the file system looks OK.

I’ll report back once I try the reinstall after app zapping and a fresh download.

Well I tried the App Zapper solution a couple times and, sadly, only the sorter issues were sorted out. Preferences are still not available. What’s the name of the log file that would show any problems encountered during the install?

At this point you would get the best response by contacting You’ll want to open the Console application (in Applications > Utilities) and check what’s being logged when you start DEVONthink. Then copy it, and send it to the email address above. You can also refer to this forum thread in your email.