My search queries doesn't return anything

I am trying to search my DEVONthink files, but none of my searches return anything but “Search. No items found!”


When using the search box in the upper right corner DT searches only within the scope of the selected files or groups. Uncheck everything to search through all documents.

jp mentioned the main problem, there is another trick: the search is allowed in file names, paths, URL, comment, content. This can be checked with the triangle in the search dialogue. Did you accidently search in file names while you wanted to search in content? Or something like that?

Thanks for the replies. However, I’ve tried all this. The search function has worked flawlessly for several weeks (since I installed DT), but suddenly stopped working. Other functions in DT fails to work as well — for instance, the upper left buttons (“go to top…”) don’t respond at all.

I just registered DT, hoping that all this was due to the lack of a S/N, but that was not the case.


I agree. I’m having problems with searches. I know words are in my data but DT returns a null string. Also I can’t get the go buttons to do anything.



The Go buttons only work when you e.g. double-click a group to open it in a separate window. Then you can climb up the hierarchy step-by-step or to the root.

What have you changed that it doesn’t work any longer. When did it stop?



Thanks Eric,

That explains everything. Works fine now.


I just checked out these features on my old DT 1.9a database, and they are working for me.

Eric’s and Maria’s comments seem to have solved the problem.

I posted a General Troubleshooting Tips note for more serious problems. :slight_smile: