Need help Idisk script produced HUGE file


I am currently running Devon Think Pro 2.02 on a Mac Pro tower. My database file is 1.57 gigs in size. I have tons of room on my idisk.

Several days ago I ran the export script “Backup to Idisk”. The script got to “archiving” and got stuck there. I left it alone overnight, the next day still in the same spot, Devonthink was locked up, so I had to force quit. Yesterday, I got a message saying my hard drive was full. Just last month, I have carbon copy cloned from a 500 gig to a new 1 Tb disk, so had 550 gigs of space.

I started searching and found a file in Users/mdaleallen/Library/temporaryitems containing a file named:

MDaleAllen.dtBase@ 10-04-06/zip that is 469.96 Gb in size!! I have been unable to delete it as the trash just hangs on “emptying the trash”

Does anyone have any recommendations on how to proceed and more importantly, how to prevent this from happening in the future?

Thanks in advance.

M. Dale Allen

That’s a really strange issue. The script uses the “compress database” command which…

  • verifies the database
  • optimizes the database
  • zips the database (without the additional backups inside the package)

…and therefore the resulting zip file shouldn’t require more space than the database package. The actual creation of the zip file is done via /usr/bin/ditto.

Does your database package contain any aliases/symbolic links (actually it shoudln’t) and is the filesystem of the volume fine? Does this happen using a new, small test database too?


I didn’t think to check the disk. I will run the disk utility tonight.

I will test that tonight.

thanks for your help!

Dale Allen

  1. Ran disk repair and applejack last night again ( the new applejack for Leopard) No big problems

  2. Tried running export to idisk again last night, got a hug file once again, this time 466gb, in the same folder, after forcing quit as it was locked up again.

  3. Tried running export to daily archive, got to the step three “zipping” and locked up. Had to force quit.

Any other ideas of anything else I can try? I am getting concerned because the only backups I have are on time machine and would like to compress the database and put it on DVD and in the cloud.

Thanks for your help

Dale Allen

For your database size, the zipping stage of the creation of a backup archive can take some time. That should not be confused with a lockup.

My God, you are fast to respond, Bill! thanks.

I am, indeed, an inpatient person, and I probably only waited about 10 minutes or so. I will try again tonight and let it go longer.

Any idea on the idisk script producing the giant files? What is interesting about it is that it makes the file big enough to completely fill up my 1 Tb harddrive ( left 8 Mb open last night)



  1. Gave the zipping 120 minutes, no dice. Still zipping, locked up.

  2. Backed up a 1mb test db to idisk without problem.

Could my database somehow be corrupted? Everything seems to work fine. Currently at the latest version of DT Pro. Mac is at 10.6.4 running on a 2x2.66 Ghz dual core xenon mac Pro.

I assume that you used Force Quit when you decided the application was locked up.

When you next opened that database, you should have seen a “database in use” warning, as the database had not been properly closed.

In that case, there is a possibility that the database has been damaged. It’s a good idea to run Tools > Verify & Repair whenever you see that warning message and proceed to open it by clicking on the Continue button.

Even if no errors are reported, in your case I would recommend either a database rebuild (Tools > Rebuild Database) or alternatively, a complete export of all the contents of the database to a new folder in the Finder, followed by capture of ALL the content of that new Finder folder into a new database. Reason: possibly some of your files became damaged because a write operation was incomplete, for example.

In either case, rebuild or export/import, check the Log (Window > Log) for reports of files that failed to make the rebuild or export/import procedures.

Still fighting with this problem. You were completely right about me having to use the force to quit and getting the database already open warning.

I did the full Rebuild database and tried again. I did not get the gigantic file produced by the save to idisk but it got stuck in the script. I gave it four hours and it was still in the last step.

Now, I find that I am unable to do a simple drag to copy my database to my NAS server. It copies about a third of it and then I get an some type of error and it says it is unable to perform the copy.

It must be some type of error in my database, right? I did the rebuild database. How exactly do I accomplish the alternate manuel method you mention above?

Of note, Devon is working fine otherwise with no other issues.

Thanks if advance for your excellent help and advice.

There are two possibilities:

  1. Create a new database and move everything from the old database into the new database (via drag & drop or via the contextual menu)

  2. Export everything via File > Export > as Files & Folders…, then import the exported stuff via File > Import > Files & Folders… into a new database.