New MacBook Pro AND new iPhone & iPad Not Syncing

I went all out for myself this season and upgraded my Mackbook Pro, iPhone & iPad. I bought my new MacBook Pro in early December. I did a complete reinstall of everything — moving my databases and application support files. All worked out well. Things were fine on the Mac and syncing seemed to work fine on the iOS devices.

I had not originally planned to upgrade the iOS devices this year — but a nice Christmas bonus came along. I upgraded to the iPhone 11 (256) & iPad Pro 11" (256). I transferred all files from the old devices through iCloud backup.

My new iOS devices now have the same files I already had in DEVONthink to Go — but new files from the Mac are not syncing. However, all the devices show they are syncing. When I open the list of databases to sync on all three devices, they give a last sync time consistent with the last time I opened the program.

What do I need to do to restart the sync process between the three devices? BTW, I am using iCloud to sync. All the programs and operating systems are the. latest versions. Thanks.

It’s no surprise it’s an iCloud sync, given the issues people are having with it (not just our customers).

  • Is there anything reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it and tell me what it reports.
1 Like

Thanks for getting back to me so quickly.

I’m afraid there are no issues reported in the DT3 log. Likewise, the little cloud in DTG appears without any triangle — and nothing happens when I touch it. When I look in settings, it indicates that the sync happened when or soon after I last opened the program.

Should I just delete all the sync everywhere and start over? If so, just a few pointers on what to do — and not to do — would be very helpful.

Thanks again.

You’re welcome :slight_smile:

It is quite possible iCloud has stalled - a condition over which we have no control, nor can we even detect it. We can’t reproduce this issue, and some have said it “just started working!”

Here are a few things people have said “worked” , though we obviously can’t test it since we can’t reproduce it. I would try them individually…

  • Reboot the problematic device(s).
  • In DEVONthink’s Preferences > Sync , disable the iCloud location and quit the application. Relaunch DEVONthink and re-enable the sync location again.
  • In iOS’ Settings > your Apple ID > iCloud, try disabling and re-enabling iCloud Drive and DEVONthink.
  • In iOS’ Settings > your Apple ID, sign out of iCloud and sign back in.
1 Like

Thanks. I’ll try doing that.

Hi Robbchadwick, I too have all of the above, and I find that most of the syncing works thru the iPhone.
In fact most settings should be set in iPhone first. Also for text Messages, you need to go to preferences on your mac and go to iMessages and select everything there (all emails and phone #). This will sync all text messages on your computer to your iPhone, and convenient feature. HTH