New release still in demo mode?

I’m not sure if I’m getting the nature of the problem correct.

I’m assuming DEVONthink Pro Office 2.0 is still running in demo mode, in spite of the fact that I have a license.

I’ve attached a screenshot that shows the message I get when I’m trying to import email from Apple Mail into a newly created database.

I tried re-entering my license key. It didn’t make any difference.
Screen shot 2010-02-24 at 9.38.32 AM.png

If you had registered DT Pro Office during the public beta period, it should have remembered your registration; it did so for my copy.

Check your license code email to make certain that your registration is for DT Pro Office (not DT Pro, which has a different license code).

If you have the license code email for DT Pro Office 2.0, enter the information components (Name, Organization (if any), License Code) into the corresponding fields of the registration panel (Help > Enter License).

After entering the last field, press the Tab key. The Register button should activate so that you can click on it to finish.

I ran into the same problem, DTPO 2.0 is locking me out of the OCR module because it believes to be in demo mode. (I just emailed about the problem).

I tried to reenter my registration info, but although it shows up, for example in the splash screen, it didn’t help.
Bildschirmfoto 2010-02-24 um 20.04.30.png

Strange. I just updated DTPO 2.0 today, then OCRd a 28-page document plus several smaller ones.

Try clicking on the application name in the menu bar, then choose ‘Empty Cache’. Quit the application and relaunch it.

If that doesn’t work, perhaps your registration .plist file is damaged. You can find it at ~/Library/Preferences/. Delete the file named “com.devon-technologies.thinkpro2.registration.plist” and then reenter the information from your license code email at Help > Enter License. Press the Tab key after entering the last field of that information EXACTLY into the registration panel. The Register button should then activate so that you can click on it to finish.

I’ve tried re-entering my license code, and it still throws that same error.

I even went to the length of reinstalling DEVONthink Pro Office, after removing it in its entirety (application, plists, preferences, caches).

The result is the same.

Both “Empty Cache” and deleting com.devon-technologies.thinkpro2.registration.plist and reentering registration info, didn’t solve my problem. Please help!

Same problem here. Tried all the same fixes.



I’d like to add that on my system Mail import is affected, too. I just tried to import a mailbox and it stopped after 200 messages complaining that I use a demo license (which I do not!) - so not only OCR is messed up.

I have the exact same problem. betas were registered, my name shows up on the splash screen, mail import stops and tells me to purchase a license.

I am quite certain that I have a license for DTPO.


I’m experiencing the same thing. Posting here so I can get a notification if the thread is updated with a solution.

I’m having the same problem as above. I contacted tech support, got ticket #180689. I included a screen shot of the license window, if it helps.

Please see viewtopic.php?f=3&t=10269

Can you lock this thread so followups can go there? Thanks.

Version 2.0.1 of DEVONthink Pro Office has just been released and fixes the demo issue. Available via Check for Updates and from our downloads page.