No longer able to get into DTTG 3

Just for anybody passing: DEVONtech have now explicitly asked you don’t do that.

Free intro, haven’t paid on iPhone or iPad. I still have v2 installed on both as well in case code is checking for that.

I haven’t paid on either device. Free upgrade from v2 intro. Working on iPhone. Not on iPad.

Hmm, but there is no other way around it, is there?

Not before version 3.1.6 hits the App Store. We’re already wrapping it up but as with anything on iOS it has to go through the review I’m afraid.

1 Like

Right, so for the time being the only way around the bug is to pay, regardless what the DevonTech blog article advices

1 Like

My phone upgraded iOS to 14.7.1 overnight and now DTTG on my phone is locked on that same screen, just like my iPad.

Looks like the latest iOS breaks the subscription management somehow.

Or just use DEVONthink on the Mac for a few hours.

No, it’s a bug in DEVONthink To Go itself.

I got mine working. I had a paid DTTG 2 edition. Had gotten the DTTG 3 with free temporary subscription. Had not used for a while (therefore I don’t really know when this started) but last night wanted to get going again. Same setup on iPhone and iPad.

When I tried to use DTTG 3 last night I got the screens I showed above. Stuck at the description of the upgrade paths.

I went ahead and paid for the one time upgrade on my iPhone and it went on and let me get in. But the iPad remained stuck. No way to access anything in settings or anything. I decided to try uninstalling DTTG2. Well that made it worse. Now it said I had to buy it (DTTG3) outright. No upgrade path. So I reinstalled DTTG2. Now DTTG3 was back to showing me upgrade paths with no way to continue.

Then I decided to uninstall DTTG3. I then reinstalled it. Now I was back to the original announcement about the upgrade with the thumbs-up icon at the bottom. Clicked that and I was in. But all my databases were gone. I was able to resync the databases so no great loss.

So… short version. I had to uninstall/reinstall DTTG3 (and re-add databases) to get it working. Now it seems fine.

Thanks for sharing your experience!

For anyone else running into this: We are waiting on Apple’s review of our hotfix. Thanks for your patience and understanding.

1 Like

no problem guys!
We love DTTG3 so much, we can wait :slight_smile:

Thanks for all the hard work over the years on all the DevonThink products.

DevonThink + Obsidian, I am a happy man


And thanks for the patient, gracious, and encouraging response!

DEVONthink + @Angone = :heart:

1 Like

I recently installed my purchased version 2 on an old iPad running iOS 12. And I am running the “free intro upgrade” v3 on my iPhone.

The iPad install of v2 seems to be working - ie, it launches - though I haven’t gotten around to fully setting it up. The iPhone install of v3 is what is stuck on the purchase screen.

I hope this helps confirm or clarify the issue.

Hey guys, first thanks for your nice job u r doing.
My issue, paid on the iphone a one time upgrade, access on iphone ok gives me just the following screen. iPad access okay but not the same screen, just says option to manage for the free upgrad intro

I also have the same problem, which was there for no apparent reason. I have installed the DDTG3 update coming from the beta phase.
I can only select Manage Free Upgrade Intro (or buy one). However, DTTG is not listed in the iOS subscription management. I still can’t call DTTG afterwards.
So I will wait for the update too…

Edit: Problem solved with update 3.1.6. Many thanks for the quick troubleshooting!

I had to pay to get into the app even though it’s been telling me it’s free until the end of August. A bit annoying. I paid because I had to do something and I was hoping the charge wouldn’t apply for a couple of weeks. Oh well.
Edit: just updated and the new version doesn’t seem to know I’ve paid.

The update came through - everything is working again! That was so FAST! Thank you DEVON for the hot fix and the super-quick response!


I had the very same issue (i.e. one-time purchase on iPhone but can’t use on iPad Pro 2020) and can confirm that the latest update fixed it. Thanks!


I can also confirm that update 3.1.6 is available and fixed the issue for me.

Thanks for the quick response and fix!