No way to move large amounts of data out of DTTG on iOS/iPadOS?

I’m trying to copy some data out of DTTG on my iPad. But there doesn’t seem to be any way to achieve this reliably. Options I’ve tried are

  • Drag & Drop folders from the “DEVONthink To Go” location in to other locations. This usually fails in halfway if the folder contains subfolders with error saying “can’t communicate with helper”.

  • Drag & Drop groups the DTTG app to Files app. This always fails with error saying “can’t load representation of public.folder”.

  • Sharing groups in DTTG app is not supported.

  • There’s no database export functionality in the app.

Is there anything else I could do without involving a Mac?

Groups don’t exist in DEVONthink To Go so no, these options will not work.
And in general, moving large amounts of data is not something iOS / iPadOS generally excel at. :slight_smile:

If you have a Mac, such curation is still best done on it.

I regularly work with a few hundred of gigabytes of footages on ipad. I don’t think it’s unreasonable to move a few gigabytes of data given my ipad pro has 2tb. I don’t have a Mac anymore and intend to use DTTG standalone but these restrictions are a bit like soft lock-ins. Hopefully it can be improved in this area.

Why use DTTG standalone?
imho This application is a supplement to the Mac application

I don’t have a Mac anymore … restrictions are a bit like soft lock-ins

For sure, DTTG doesn’t have a mass export feature, but I’m not seeing it as a lock-in
Honestly, before losing my Mac I would export my data and look at alternative solutions

1 Like

I don’t think it’s unreasonable to move a few gigabytes of data given my ipad pro has 2tb.

It’s not a matter of reasonableness or the capacity of your device. It’s a technical matter involving a specific aspect of our application and the filesystem. Perhaps at some point using groups in the way you’re describing may be feasible, but it’s not at this time. However, using files is.

Is that what’s in the app description, or is that how you think the app is?

Btw this is from DTTG’s app store page

DEVONthink To Go is the mobile document management solution for iPad and iPhone.

What I’m observing in my option 1 is that the process often works half way through before the error kicks in. Apparently it can copy some files and folders this way, which makes me think this is a bug instead of technical impossibility.

I assume this won’t be relevant, but have you tried setting the security setting from immediate or a small number of minutes to the maximum (30 mins)? Is the failure apparently related to the time set here?


I knew the limitations with security so I actually turned that setting off.

I thought you might have; sorry, I’ve not got any other useful ideas :slightly_frowning_face:

Thanks for the inputs!

Maybe you could open a support ticket so we can add it to our bug tracker? That would be very helpful.

Will do.