Occasional thumbnails not generated properly

For many of my PDFs, the thumbnail doesn’t generate properly and is cut off. See the screenshots below for an example; the first one is how it should look (and how it appears in Finder), the second is the thumbnail in DT.

Screenshot 2021-12-04 at 22.43.49

Screenshot 2021-12-04 at 22.44.06

Another example:

Screenshot 2021-12-04 at 22.49.38

Screenshot 2021-12-04 at 22.49.10

If I open these files in DT, then they show fine. I tried moving one offending file to trash in DT and then re-importing (by dragging from finder), but same problem. Also tried removing the thumbnail and then re-creating it, but again same problem.

Try disabling Preferences > Files > Thumbnails > PDFs and reimport the file. Does it look as expected?

If I do that, it just has the generic PDF thumbnail rather than the proper thumbnail. If I right-click and select “create thumbnail”, I get the same problem.

Attached is a single-page PDF that has this problem, as an example.

Flight Sim Keys.pdf (156.4 KB)

Are you on an M1 Mac?

No - 2016 Macbook Pro.

What OS - Monterey?

Yep, Monterey 12.0.1.

One potential clue - for many of the items in question, the first page (i.e. the one the thumbnail is generated from) is smaller than the subsequent pages. This does not seem to be the case for them all however, such as the single-page example I sent you. Also, I have found some items where the first page is smaller, but the thumbnail is fine. So maybe it’s not that.

Another clue - convert to PDF (paginated) seems to fix the problem. I don’t know what doing that does to the PDF file though?

Please send an example document to cgrunenberg - at - devon-technologies.com - thanks!

I sent one - see the PDF link a few messages above. I don’t have that file on my own machine anymore, as I converted it as mentioned above.

Thanks, I’ll check this.

1 Like

It’s an issue of Monterey’s PDFkit framework, the next release will include a workaround.

1 Like

In the end, the workarounds will be larger than PDFKit itself :frowning:

I doubt that… even the PDF specification is huge (756 pages), it’s one hell of a format :sweat_smile:

2 Likes

Glad you found the issue! Can you say more about what the issue is with the PDFKit framework? Will the workaround in the next release require any sort of re-import or re-scan or anything @cgrunenberg ?

Also, surely I’m not the only one using OS Monterey lol. How come no one else has raised this issue?

You might have to update the thumbnails, that’s all.

Is there an easy way to update all thumbnails en masse?

Data > Thumbnails > Update

1 Like