OCR function stopped working

Dear members of DEVONtechnologies,

After upgrading to MacOS Sonoma the OCR function within Devonthink stopped functioning. Everytime I try to OCR a pdf (or any other file) it only states ‘adding document’, but never starts or finishes the operation. I tried reinstalling DEVONthink, but to no avail. When I go to library/application support/Devon Think/Abbyy the icon of DTOCRhelper has a large stop sign over it. Clicking it says the application is damaged or incomplete.

  • Tried reinstalling DEVONthink
  • Gave full disk access to DEVONthink and DTOCRhelper
  • Tried uninstalling and reinstalling Abbyy’s DTOCRhelper.

Problem persists and DTOCRhelper icon stays the same.

Hope you might have any ideas I could try.

Thanks for any help.

Which version of DEVONthink do you use? Intel or M1/M2 Mac?

What is the Resolution set in Preferences > OCR?

Thank you for your quick reply. I use a Macbook Air 2020 M1 and I’m currently using version 3.9.3 of DEVONthink (server edition).

“as source”

  • Is the document in the Global Inbox or a separate database?
    • If a separate database, is this an encrypted database?
    • Where is the database located?

Global inbox and or other databases (located in user folder) all behave the same. No database is encrypted.

Perhaps there’s something logged. Hold the Option key and choose Help > Report bug to start a support ticket.