OCR not working with 2.9.7


With 2.9.7. I cannot convert a PDF to PDF+Text anymore. Process starts and finishes, but the result is still a plain PDF.

Any idea how to fix it?


Nothing wrong here. What operating system are you running?

10.12.2 Beta (16C41b)

“Beta” - the magic word!

Does it work again after restarting the computer? Otherwise please choose Help > Report bug while pressing the Alt modifier key and send the email to cgrunenberg - at - devon-technologies.com

Same here. No Beta. Final version

Public beta - we help the guys to make the solution work when it is out of beta.

You think Apple listens to beta testers? Seems to me that Sierra proves they definitely do not.


I OCR:d 828 .png (screen shots) and OCR inside DTPO worked perfect! have 2.9.7 and Sierra 10.12.1.

I’ve noticed shortcomings with scanning and OCR since 2.9.7 as well.

The scanning doesn’t appear to do OCR any more. I have to select the PDF in the database and select Data > Convert > to Searchable PDF.

(In preferences, under the OCR tab, I have checked the box "convert to searchable PDF.)

Also, there no longer appears to be the option to combine multiple scanned pages into one PDF.

The same behavior as avatar mentioned.
Combine two pdf pages will not get the right order. I name the two files with suffix 1 and 2 and also I will not get the right order of the two pages.
MacOS 10.12.1 (Sierra) and DOpro 2.9.7

Did you use Data > Merge? Then the displayed order should be used.

Same problem exists with latest beta from last night.

I just installed the 4th public beta, downloaded DEVONthink Pro Office 2.9.7 from our website, installed it in /Applications, installed the OCR resources and was able to OCR documents afterwards.

Is DEVONthink Pro Office installed in /Applications? Is there anything special about your system, e.g. is your home directory located in /Users or somewhere else?

I have a SnapScan. Nevertheless there seems to be a problem to find the settings of SnapScan. Opening the settings of SnapScan does not solve the problem.

Konnte keine Voreinstellungen der ScanSnap Manager-Anwendung finden. Starten Sie die Anwendung, wählen Sie das Menü „Setting…“ und anschließend „OK“. Danach beenden Sie die Anwendung und kehren zu DEVONthink Pro Office zurück.

Which version of the ScanSnap Manager do you use and where is it installed? In the folder /Applications?

3.2 L80 - re-installed


The same at problem at my fresh installation of macOS Sierra beta 4 and DVOP 2.9.7 and SnapScan Manager 6.3 L50 !

No OCR only plain PDFs .

All application are installed in the application folder.

Bye Ralf

macOS 10.12.2 is a beta release and should NOT be used in mission-critical or production environments, nor should it be expected to behave as expected. Betas are a moving target code-wise. We code for public releases as the code can change substantially in the beta process. Again, you should NOT run beta operating systems on a machine you need to be working.​

I cannot be too sure about this but my impression is that OCR-function stopped working alltogether after I installed 4th beta (10.12.2 Beta (16C53a)). Not even the action from the contextual menu worked.
I did a drastic thing and removed my DTPO installation and then re-installed it. After this, everything is working perfectly again.

The Automater “OCR Item” is still not working.