Odd search behaviour

Hi. This one is strange.

I wanted to see all the documents in a folder, no matter how nested in sub-folders. I used Search with All/ Any word/ Ignore Case/ attributes set to Any/ search in the folder I wanted/ search field left blank. I have done this many times before, and it’s always done exactly what I wanted.

But this time it came up with No Results, even though I could see there were many documents in there. Tried another folder, and eventually the whole database. Same - no results. I then put words in the search field, and it worked (as far as I could tell) perfectly. Took the words out - no results. Repeated the whole thing many times, told myself I was doing something stupid, verified, optimised and restarted, and finally decided to ask for help here.

What I’m seeing is “no results” returned on a wide search, and results returned on a narrower. How can that be?



Searching requires either a non empty search string or an attribute (e.g. label is x, state is on/off or locking is on/off)

Ah, all is clear. Thank you. Strange - I was sure I’d done it many times before, but maybe I’d always set the label on those occasions… my bad, sorry.

Still, this does seem a minor bug, doesn’t it?

Thanks again

Can’t resist: Why should a search for nothing return everything? :smiley:

Dunno. Same reason I guess that nothing’s better than Heaven.