Oh please, help with mail script!

I have searched and read on how to import mail.app messages to DTpro. However, in my script menu, under MailScripts or under DevonThink Pro, there is no “add message to DevonTHink”. There are other scripts like “Copy Selection to Incoming” under DevonThink Pro script folder and others under the MailScripts folder.

I’ve downloaded the application several times and installed it. I’ve done the “Install add-ons” but the script just doesn’t come up.

I want to have most of my mail in DTpro so I can have them with the subject I’m working on.

I’ve done the “select the e-mail you want to import. Select All, and drag.” But I only get the headers with a Safari symbol on the bottom.

Please help.


There’s an issue related to the “Install add-ons” in v1.0.2. Deleting the folder ~/Library/Scripts and using the command again should fix this.

I’ve got the same problem. I tried the Deleting the Scripts Folder in Library, but there are no new scripts anywhere. Not in the ‘Addressbook and Mail’ folder, or the Import folder.

Grateful for any help!

After deleting the script as Christian suggested, in DT Pro select Help > Install Add-ons. That will reinstall the scripts.

The scripts will be available in Apple’s global Scripts menu when Mail is frontmost.

I’ve deleted the library script file and installed again, but still no email download script appears. More tips anyone??

confused in Austin

Did you activate the global scripts menu extra? See Applications > AppleScript > AppleScript Utility.

Yikes. I open apple script in application and I don’t HAVE apple script utility… I have only:

Example Scripts
Folder Actions Setup
Install Script Menu
Remove Script Menu
Script Editor

even more confused…



Just use “Install Script Menu” (I guess you’re still using 10.3.9).

okay, I’ve punched install script menu. Then I’ve tossed the old Devon scrip file and reinstalled. Now I go to script icon and…it looks just the same.

I must be screwing something up…

What’s in the folder ~/Library/Scripts/Applications/Mail? Note: The script menu is application specific, you have to switch to Mail before checking the menu.

Okay, I don’t know what I did, but I think I did it. I’m using Entourage, so I fooled with those files…

thanks a million…