Omitting wildcards in searches


in my field of research there is a parameter called a*. It shows up in a lot of notes and PDFs that I have.
My problem is that I can’t figure out how to search for it, as searching for a* returns all words starting with the letter a.

Is there a way to omit the wildcard and to tell Devonthink to treat it as a character?

If already tried to find a hint in the manual and searched the forum.

Any help is appreciated.

Until the gods reply, I’ll provide this… Use * to indicate “*” (as a regular expression).

Doesn’t seem to work that way, over here. a* does not find a* in my testing.

DEVONthink will only search for alphanumeric characters, with the exception that ‘’ and ‘?’ are wildcards. Even if you could escape the '’ with a regex operator, I would expect that ‘*’ would still be unsearchable as are all the other non-alphanumeric characters.

Assuming that you have enabled Spotlight searching for your databases, you can search for ‘a*’ with Spotlight and then save the search.

You could try a[^a-z]. As wildcards as literals are ignored, you can’t extend this to a[^a-z0-9] to find non-alphanumerics but unless you have occurrences of a1, a2, etc. this may work well enough for you.

Hi there,

is this limitation still there in Devonthink? I would like to search for “(Author)” including parenthesis.

Cheerz, Tekl

Non-alphanumerics are still not indexed, therefore not searchable.