One database among many not synchronizing

I have a situation where one database isn’t syncing, while others are, for the same sync location.

Observation: All databases show last synchronization with a “recent” time, while this one is a couple weeks in the past.

I have seen previous posts such as this one and this one, but I didn’t see reasons or clues there so making a fresh post.

Some FAQ:

  • database size: 1.8G
  • iCloud size remaining: a few 100G
  • verify location runs without error

Well, what do you know?

I should’ve tried one more thing before posting, sorry about that.

I clicked on Verify & Repair Database, and it ran and failed.
… which I’m not super worried about because this database does index some stuff on iCloud and I’ve seen this happen once before and I don’t fully understand it but I sort of give it a pass :man_shrugging:

No immediate change, but after a few more minutes, I now see the “last synchronized” times match up.

So, problem solved.

But while we’re here, if someone ends up reading this, any clues on how to interpret the “failure to repair”? (my gut feeling is that it’s a false negative, but how do I make sure?)

What was reported to the log window?

There were a few missing files.

One example is attached:
Screen Shot 2021-05-17 at 5.22.35 PM

(I should clarify these are all in an indexed group)

I investigated this example further:

  • As the path implies, this is within an Obsidian Vault
  • It is indexed
  • It was renamed within Obsidian (i.e. created with that 2021...302 name and then renamed to add a few words after that)
  • The renamed file exists within Obsidian
  • The renamed file exists within DT too
  • The “original” file shows up in DT, but with a “File missing” preview.

The handbook has a section on missing files and what to do about them. Have you tried those steps?

Thank you – I was, embarrassed to admit, unaware, and this was very useful.


That’s good to hear - so is everything working for you now?