Open document internally

Due to numerous requests, DT added some time ago the option “Double-click opens document externally”. Once this is chosen, I seem to be unable to find a mechanism to open documents with the internal viewer/editor (say markdown files). Am I missing something? Would it make sense that the internal viewer/editor would at least appear in the “open with” contextual menu. Or, ideally, that option toggles the mode:

  1. “Double-click opens document externally” checked
  • double click opens externally
  • option-double click opens internally
  1. “Double-click opens document externally” not checked
  • double click opens internally
  • option-double click opens externally

Rationale: for pdfs, I very much prefer to open straight into Apple Preview. But for Markdown, I want to open into the internal standalone editor. It allows for working in a distraction free window (vs. the internal editor/viewer pane in the main DT window). Since I use item links for embedding links and images in my DT Markdown docs, external apps like Typora really don’t work.

So between pdf and md, a global “double click opens …” does not work well. But a single modifier key could fix that.

Why don’t you just disable the option and use Shift-Command-O to open the PDFs externally?

Why don’t you just disable the option and use Shift-Command-O to open the PDFs externally?

Good point, after using the “open externally” option since whenever it became available, I had forgotten about shift-cmd-o (is it advertised anywhere in the menus?).

Sadly, shift-cmd-o is not symmetric, it does not work the other way round, if “open externally” is checked. At this point, pdfs are still more frequently opened here than md, so I’d prefer the simple double click on pdfs to open in Preview, and use something like shift-cmd-o on the md files. But hey, can’t have it all!

1 Like

Data -> Open with (might not be data, the menu every right of Edit). The default entry is marked with Shift-Cmd-O.
Also, you can have “open externally” checked (so that double click does exactly that) and then use Cmd-O to open internally.
Or maybe I didn’t quite get what you’re after.

Duh! Didn’t see the forest because of all the trees. When ‘open externally …’ is checked, the menu item “open” still opens internally (or, on the keyboard cmd-o, as you point out). Why did I not realize that? I must have automatically assumed that once the double click is set to ‘open external’, the open menu item would do the same! Good that I’m not in charge of control systems in nuclear power plants.

You’re welcome :grinning: