Opening files with their respective program

Every time I double click on a file, it opens in DTOP’s native viewer. To get it to open in it’s own program, I have to go to the contextual menu and click on “open with.” The correct “default” programs are always at the top of the list (Skim, Mellel, Word, etc.), but these only open when I use “open with.” Is this normal behavior…or have I been unable to find the preference that allows automatic opening with a files default program on double clicking it?

Double-clicking will always open the document within DEVONthink.

To open a selected document externally, click on the Toolbar icon, ‘Open in external editor or viewer’ – for recognized filetypes this will display the default application when a document is selected. So if you have a PDF selected, the Toolbar icon will show ‘Open With Preview’.

Alternatively, Control-click (right click) on a document and choose the contextual menu option, ‘Open With’. Preview will be shown as the default, but there is a list of other applications that could open the PDF.

Thanks Bill. I would like to suggest a preference to open the default program or the DT viewer on double click.

Not on my system. At least files from Mellel, OmniGaffle and Numbers are opened in the respective program when I doubleclick them. I suppose that file formats that DTP can handle natively (like plain text, rtf or pdf) are opened within DTP and other formats are opened externally.


@Johannes…thanks for confirming this. I thought I remembered this functionality in a prior version (for me at least)…but couldn’t find a preference when it stopped working. It’s been bothering me ever since…and I was at the point of being convinced my old mind was just remembering incorrectly. I too was able to open many files by directly double clicking on them…and then files not supported by DT were opened by the DT viewer. Now ALL my files are opened in the DT viewer unless I use the contextual menu>open with.

Every time I double click on a file and it doesn’t open the default program for viewing it I get frustrated, because I recall DT performing that way in the past. I hate using the contextual menu EVERY time I want to open a file in it’s native program.

Now I’m really curious why it is working for you but not me.

I stand corrected. You are right. :slight_smile:

All of the major reference collections that I’ve built up are in text, HTML, WebArchive or PDF. Of the tens of thousands of references including journal articles, books and reports, governmental publications, etc. those filetypes are used in the fields that I cover. All of my notes ‘attached’ to those reference materials are in rich text.

When I’m working with those references I usually open them in a new window by double-clicking, and keep a rich text note window alongside the reference document. I like that environment, as I’m within the DEVONthink environment regardless of the filetype of the document I’m reading. I’m not bouncing around between separate applications to read PDF, text, and Web materials.

I often switch to Full Screen view when reading a reference. If I want to make a note, I pop back to normal view and enter the note in the rich text document that lies alongside.

So my immediate response that double-clicking opens a document in a new window inside DEVONthink is an artifact of my own workflows, and the filetypes of my reference materials.

I do have a few files that don’t act as I’m accustomed. I don’t like that! Oh well, most of them aren’t very important, and I can use DEVONnote to take notes about documents that insist on opening outside my database environment. :slight_smile:

I probably cheat a bit. Powerpoint presentations can be saved as PDF, for example. But it’s not often that I see a Powerpoint presentation that I want to keep.

What I want is more and better Quick Look plugins for those weird file types that currently don’t open in their own windows in DEVONthink. :slight_smile:

You can assign shortcut keys to open them in their native applications. I think that this behaviour is reasonable. However, what I find a bit annoying is that if you do assign shortcut keys to “open with” a particular program, the shortcut keys only work after the first time you open from the menu on your initial loading of DTPO. Once they are opened the first time from the menu then they open using the shortcut key. I use WriteRoom as my main rtf editor (I can’t live without typewriter scrolling) and have just assigned it a shortcut key, but as I say above, this is less than smooth until the first time it is opened from the menu. One of the great strengths of DT is its ability to work with external programs.

While assigning shortcut keys is a reasonable work around, I would still like to see the preference to open documents in whatever program I desire. I can set these attributes in Finder under the “get info” window. I would like to see similar options in DT for each individual file type (if not individual file like in finder).

 I use WriteRoom as my main rtf editor (I can't live without typewriter scrolling) and have just assigned it a shortcut key, but as I say above, this is less than smooth until the first time it is opened from the menu.
You may try this AppleScript:

tell application id “com.devon-technologies.thinkpro2”
set rRecord to the content record of window 1
set cPath to path of rRecord
set cFile to POSIX file cPath as string
end tell

tell application “WriteRoom”
open alias cFile
end tell

It will open the document shown in the frontmost viewer of DTP in WriteRoom. Save the script into DTP's script folder and assign a shortcut (either via SystemPreferences or by adding something like "___cmd-Option-ctrl-shift-w" to the Name of the script (this is: three underscore and then the modifyer keys) don't forget to refresh the script menu with the second command in the menu befor trying the shortcut.

Hope this helps.

@Johannes…thanks. I’ll give this a try until the “powers that be” decide to add a preference to a files “get info” pane in DT that allows assigning which application you want to open this file (or all similar files), similar to the preference in “get info” for a file in Finder.


I tried to post an image…that didn’t work too well. Would somebody explain how I either attach or link to an image? I tried to link to a public flickr photo…that didn’t work obviously. I also tried to attach the picture directly…and couldn’t. I read the FAQ’s…but am too computer illiterate to figure it out :blush:

Ein Link sollte so aussehen:



“A link should look like this:”

Johannes illustrated how to link to a Flickr image.

If you want to attach an image to a post to this forum, you can follow these steps, assuming you’ve already logged in and have opened a “post” or “post a reply” window:

  1. Type in your message
  2. Just below the post field are three buttons: Save Preview, Submit.
  3. Below those buttons are two tabs: Options (active) and Upload Attachment (inactive)
  4. Click the Upload Attachment tab
  5. You will see two new fields: Filename: and File comment: Click the “Choose File” button and you’ll see a typical Mac Finder window where you can navigate and select which image you want to attach.
  6. Click “Choose” in the lower right corner of the Finder window
  7. Click “Add the file” button next to the Filename field.

Not done yet…Now you’ll see a new box pop up titled “Posted Attachments” where you can enter a comment for the file. You’ll also see the name of the file in green below the “File comment” name to the left. You also have two self-explanatory options: To “Place Inline” or to “Delete file.”

Once you’ve placed the file at the point of insertion (where the I-beam cursor is) then you can continue typing further text or Preview the post, which is highly recommended. If the attachment isn’t where you want it, simply copy the string that resembles that in this image.attach3.png Insert this string* wherever you want your image to be shown when viewed by other readers.

*The name of the image in the above example is attach.png.

Hopefully this long-winded explanation will aid you in future image attachings.

Thanks Johannes and Twicks

It deserves promotion to somewhere it can be easily referred to later if someone else needs similar assistance.

Many many thanx! :smiley:

I tried it. One anomaly with it is that it requires you to quit WriteRoom completely to open a file from DT. So, if you just close a file off in WR it won’t open anything else, or if you leave something open it won’t open something new in front of it, unlike just assigning a shortcut key from the menus. Any way of tweaking this to make it work even when WR is running? I’d be very grateful.

I am not sure whether I understand the issue. I tested the script with Mellel (I don’t have WriteRoom) and it behaves like it should. It sounds to me that WriteRoom has some difficulties here to deal with the open command under certain circumstances (full screen problem?). Perhaps someone else could help?


Ok. I see that it does work in Bean.

The problem in WriteRoom is that:

it won’t open an item, any text item, once you’ve used the script once, until you shut WriteRoom down or quit it. It won’t, among other things, open a document if one is already open. Normally WriteRoom just opens new documents in front of old ones and you flip between them in the usual manner. Perhaps I’ll post on the WriteRoom forum to see if anyone has any suggestions. Mean while, if any scripters out there can lend a hand that would be brilliant.