OS X Lion incoming network connection


Since the update to Lion and the latest DT Pro Office version, OS X nags me if I want to allow DT to accept incoming network connections again on every launch. Is there a solution for this?


The problem is most likely with your firewall and/or proxy settings, and possibly if you have Little Snitch or other network software installed. If nothing changed in your installation of DEVONthink other than the upgrade to Lion, then DEVONthink is probably not the culprit. There are a number of threads on discussions.apple.com about this problem.

I recently got a new Mac and in the process jumped straight from Snow Leopard to Mavericks, so I’m not surprised this problem hasn’t gotten much attention in 2 and half years. I’m hoping someone can help. This “…accept incoming network connections?” dialog pops up at every launch.

There seem to be 2 main solutions floating around for this problem: resetting the firewall (and deleting its prefs file), and completely uninstalling then reinstalling the app. I did both for good measure (backing up the global Inbox first). Things seemed to work for a few hours after several launches/shutdowns/restarts, etc. Then a few minutes ago, I clicked the DT extension icon in Safari, which launched DT, and there it was again. I’ve spent hours trying to fix this.

I don’t have Little Snitch or anything like that. The only network-specific app I have running all the time is the OpenDNS Updater, but I don’t see why that should have anything to do with it. The only really coherent thing I could find about the issue is this:


I’m not ready to “sign the application myself” (and shouldn’t have to), but I did go through Step 1 on that page, which was to verify that there’s a code signing problem. I followed the instruction and Terminal returned a long list of lines, all starting with “–validated:/Applications…” like the first few here, except for this at the very end:

So hopefully this provides some real data that one of you out there can use to suggest a solution. I’ll follow the instruction to sign the application myself if the DT developers tell me to, but I’d rather avoid that.

Thanks in advance.

Problem solved, I think. A search for a phrase in what Terminal returned led me to this:


It’s my fault, because I guess I’ve been using CleanMyMac 2 and at some point I had enabled the option to “clean” code-signed apps. The CleanMyMac developer chimes in on that page somewhere and explains what’s going on. Everything’s actually working the way it’s supposed to… By letting the utility remove some of DT’s files, it caused it to trigger the firewall dialog at every startup. Guess I’m in for another reinstall…

Sorry to have made you read all of the above post; it’s just been very frustrating trying to get rid of this issue.

I don’t user any of the cleaner or uninstaller utilities. Unless they are carefully designed and used the possibilities of unintended consequences would worry me.