Panther problems

I have just finished erasing my hard drive and installing OS 10.3 (Panther). I have moved all my DEVONthink database files into ~/Library/Application Support and cannot get DEVONthink to open them or to create a new browser. The entire File menu down to “Page Setup” is greyed out. I’m using version 1.7.2 on a Powerbook G4 (1 GHz) with 512 MBytes RAM. Any suggestions would be welcome.

Please delete the preferences file (com.devon-technologies.think.plist), disable third party extensions if necessary or verify file privileges (e.g. verify that you are able to access the database files).

BTW: Is there anything logged in the system console related to DEVONthink?

My problem solved itself, but I’m not sure how. Another problem has recently surfaced, however. Whenever I click on a DEVONthink document, DEVONthink crashes. I reported this to Apple. I can add new documents to groups, but trying to open any document causes the crash.

Could you send us the crash log too? Because I would be surprised if Apple reads logs not related to their software. Thanks.
In addition, which view do you usually use?

Well, my problem with DEVONthink crashing when I try to open a document is solved. Nearly all my documents were imported into DEVONthink as .rtf documents created by Nisus Writer Express. After I (finally) realised that I could open .txt and .pdf documents without trouble, I tried opening all my Nisus Writer documents in TextEdit and saving them there before importing them into DEVONthink. Those documents could be opened in DEVONthink without difficulty, so it seems like the rich text format specification used by Nisus Writer Express was the entire problem. The solution will be to convert all my Nisus Writer docs to TextEdit until Nisus fixes the problem. If they don’t, I’m afraid I’ll have to drop Nisus, which I have used for more than 10 years and have liked very much in the past.



Could you send us an example? That would be very helpful, thanks.  Because DEVONthink should NEVER crash - every crash is a bug.

As one of the developers on Nisus Writer Express, I would very much like to help.  Could you send me some RTF files from our product that crash DevonThink?  

I just did a quick test with our current internal build and other than loss of headers,footers, columns, and images (Devon appears to be using something like Cocoa’s built-in RTF reader, which doesn’t do tables or images (except in RTFD)) they opened fine.

Hello, Seth –
After upgrading to 10.3.1 the problems I was having ceased. Now any NWE file I put into DEVONthink can be opened without a problem. However, those NWE files I put in while I was still using 10.3.0 still crash DEVONthink. Other than going back to 10.3.0, which I don’t want to do, I can’t think of a way to send you a ‘problem’ file. I can’t export the DEVONthink document back to an rtf, as trying to select one of these docs causes the crash. And, if I try to put the same NWE file into DEVON now, I can do so without problem. Thus, it seems like the problem I was having was solved by the upgrade to 10.3.1. Sorry I can’t be more help, unless you have some other suggestion.