PDF Annotation Can Not Be Activated

I can not edit PDF in DT3 Pro(3.8.2) ! Are there any solutions?

How did you try? What happened when you tried? Is the PDF created by you or others? Is the PDF protected by the maker?

Welcome to the forum - which does feature a search function. I mention that, because the issue on hand has been discussed a number of times; a search such as PDF locked comes up with a couple of pertinent posts, for example.

Generally speaking, there are three conditions that I am aware of which may lead to the phenomenon you are describing:

  1. the PDF is locked in DT; it can be unlocked by selecting the lock icon in the inspector.
  2. the PDF incorporates a level of PDF security aimed at prohibiting editing.
  3. the PDF is not fully compliant or not fully compatible with PDFkit; DT recognises this condition and prohibits editing, as that may corrupt the PDF.

Conditions 2 and 3 may be solved by

  • using a different PDF editor (which does not use PDFkit; or - sometimes - Preview, which does use PDFkit, but has access to mechanisms not available to 3rd party applications)
  • performing OCR to searchable PDF from the context menu.

In the case of condition 3, DT incorporates a hidden preference (see handbook) which allows you to deactivate that protection; note, however, that editing PDFs which would otherwise trigger the protection mechanism is liable to destroy the text layer.


I just encountered the third phenomenon and have already tackled it! Thanks a lot!:relieved: