PDF files searchable for individual words?

This has probably been covered somewhere and I can’t find it now when I need to know.

I have a 7 page PDF file on my desktop. It contains procedures to follow in using a feature of Photoshop Elements 3. I would like to be able to put that in DTP with the end result that I could search for a word and find each instance of that word anywhere in the seven pages. I tried just simply importing the file and then I tried Printing to DTP; neither of those ways gave me the result I want.

Is it possible to do what I’ve described? If so could someone lead me by the hand?

Hi, Wayne. Just open the PDF in your database, press Command-F to open the document Find panel and enter a search word. Click on the Next button to move to the next instance.

Before putting the document into DTP I opened it in Adobe Reader and searched for a word which did not appear on the first page of the document. It returned the first instance of the word on page 2 by highlighting it. I clicked next in the find box and it returned another instance of the word on the same page by highlighting and finally I clicked next again and it found the third instance of the word on page 3.

Using this information as a guide so I knew where the word appeared I put the document into DTP and got the following results.

Command-F just gives me an error beep and nothing happens (the Find box never appears). Incidentally, the Find command in the Edit menu is grayed out as well as all the other find commands like Find next, etc. If I use Search from the Tools menu all it returns is the title of the PDF in a sidebar. Same if I use Find from the Edit menu by choosing the only available choice of In database. What am I doing wrong?

This requires Mac OS X 10.4 or later.

Ok, I’m out of luck with that. Is there some workaround? Can PDF files be changed to RTF’s perhaps? The Find feature seems to work on those file types. If so, how do I do that?

Data > Convert > to Rich text


Tried this and now I get the log popup that merely says “not converted”.

Any suggestions for fixing this new problem?

Interesting. DTP will not convert to an RTF but will convert to plain text. That seems to work but of course I lose a lot of formatting. I’d still like to know how to persuade it to convert to an RTF.

Copies of Tiger are getting cheaper all the time – and there really are advantages. :slight_smile:

I take it you are telling me that the inability to search a PDF (problem 1) and the inability to convert to an RTF (problem 2) are both because I’m not running 10.4? Why would the menu choice under Data > Convert not be grayed out if 10.3 can’t convert?

You’re a wizard at coming up with workarounds; before 10.4, how did you search a PDF?

I’ve told the Finder to make Preview the native application to open PDF files. So I can click on Launch Path to open a PDF file in Preview from my database.

In DT Pro, even now, I like the search drawer in Preview, as it will show all the occurrences of a word in the document, with a few words of context.

Christian notes that this may become possible in the PDFKit display inside the database. (But not, probably, in OS X 10.3.9).