PDF Problem

I have been a DEVONThink, and now a DEVONThink Pro user for quite a while. I have never had a problem with either program. I, all of a sudden, have problems importing .pdf documents. I also tried dragging the .pdf document on the folder where I want it. Still get an error. I am wondering if it is because I downloaded and tried DEVONThink Pro Office with the database I use for DEVONThink Pro? I decided that DTPO is overkill for me and I went back to DTP. By the way, I tried creating a new document and importing a RTF document – both worked fine. It is only .pdf documents that are giving me trouble.

Hi, Gino. I’ve switched back and forth between DT Pro and DTPO without problems, using the same database with both versions.

Question: Can you open that particular PDF file with Preview? Reason for the question – possibility of a corrupted PDF file, or a variant of the file format that PDFKit can’t handle.

Also: Try rebooting, which sometimes clears out the ‘cobwebs’ in memory.

I often get errors when importing pdfs by dragging them into DT. However, I can use the menu/import function to do it without problems. After trying Bill’s advise, assuming they open in Preview, are you having problems with both ways of importing? Does the pdf not show up at all or does it show up and you also have an error?

Reading your post in another thread, sounds like your pdf problem was solved by rebooting. Sorry you are having other problems and hope they get resolved as easily.

Alexwein, Thanks. I have a backup on my iDisk. The only problem is that my .Mac account expired. I hope when I renew my .Mac account that the backup of my DTP file will still be there.

Ah, the pitfalls of Web 2. Somehow, I don’t trust storing my data out there on a server that I don’t control.

In a related vein, I’m dubious about social tagging. Who are these people, I ask myself. What does popularity have to do with information classification, other than for show business, fashion and politics?

I myself feel quite comforted having copies of my essential files on someone else’s server. Beats having to haul things off to my safe deposit box, which is what I used to do. Backing up to CDs and other media is all well and good, but what if something happens that affects the entire house (like, knocking on wood, a fire, etc.). Or if my data gets corrupted while I’m out of town and I don’t have my backups.

My complaint with .Mac is speed, which is the usual complaint. My DT file, even compressed, is pretty huge and it takes forever to load it to my .Mac account.

gionpiazza49, sounds like your problem is solved and you got your files back. Very cool! That must be a huge relief. Isn’t Bill great? Always there to help out. :slight_smile:

Precisely the reason I’m an anarchist. Democracy is a crock 8)

I am another who can no longer import PDF files or Image files (JPGs). I can import .doc and .rtf files. I have tried rebooting, trashing pref. but it didn’t help. There is no error message, just that it failed. Any other ideas as to what the problem might be?


Have you run Tools > Verify & Repair on your database? If no errors are reported, run Tools > Backup & Optimize. We recommend that as a maintenance procedure to catch any errors while they are small and repairable, before they cascade to create serious problems.

And keep your computer well oiled an clean. Although OS X is a remarkably stable operating system, it needs maintenance. Run Disk Utility’s permissions repair and disk verify once in a while.

I use AppleJack (Google it) as a pretty simple way to run a set of OS X maintenance procedures that the geeks among us may do with the Terminal. But be sure to read the instructions and stay away from the really advanced procedures unless you know what you are doing.

A little utility such as OnyX (Google it( can do some simple tasks such as running the cron scripts.

And of course always allow enough free disk space for the operating systems and your applications to write scratch, cache and swap files. You can monitor your free disk space using Activity Monitor. Apple engineers recommend keeping 15 - 20% of your disk capacity free.

Alexandria, I never have problems dragging PDFs into my database. :slight_smile:

Thanks for the suggestions.

Personally, I use OnyX for my cache cleaning chores. For DEVON-related maintaince, I routinely run Verify and Repair which has only reported an error once (and not on this specific database). I also use Backup and Optimize.

I didn’t have any luck figuring out what the problem was so I did restore from a backup and the importing is working as it should. I’m guessing that the database in question didn’t like a jpg and once that happened, it stopped responding to import requests.

Thanks again for the help.

I am having the same problem and have tried all the suggestions for resolution I can find here in the support forums. Nothing works. Running the latest Personal version, whether using the Import menu or dragging/dropping, the beach ball spins for about 30 seconds and then the log shows an error. I’ve tried both PDFKit and PDFtotext options, but neither results in success.

I’m open to any suggestions.


Hi, sjrtyon. Tell us more. Was a PDF actually added to the database? Was the error that text could not be captured?

This would result if the PDF is either image-only (OCR would be required to create readable text), or if the PDF is encrypted, e.g. to prevent copying of the text. In either case, an error message would (correctly) result.

I have exactly the same problem as sjrtyon. Tried importing a dozen or so different pdfs (text, and mixture of text and images), and tried both pdttotext and pdfkit settings. DevonThink fails every time. The pdfs open perfectly with Preview and Acrobat.

When you try to import, DevonThink comes up with the importing progress bar (which doesn’t get anywhere), then sits there with the beach ball for about 30 seconds. Then the log comes up with an entry ‘failed’ No more info.

This is a brand new database, with just a group that I was trying to import the pdfs into. Any help would be appreciated—one of the man reason for buying the software was to help arrange my pdfs.

(this is DevonThink Personal 1.9.8 on a MacPro. Also tried this and get the same problem on a Macbook)

OK. It’s fixed now—I took out a bunch of 3rd party kernel extensions and ran Onyx, and now it works. Thanks Bill.