pdf’s turning into 1-page thumbnails

I have imported a bunch of pdf files into DT. Why are they showing up as single page thumbnails at 197X256 pixel @ 72dpi, the first page of which can’t be read, let alone any of the other pages?


Your preferences were set to capture the text as PDF+text, and to link externally to the PDF files.

Subsequently, the PDF files were either deleted or moved to a different volume, so that the file paths are broken and DT Pro cannot find the files to display them.

im having the same problem this morning, database was ok yesterday, came in this morning, booted up mac and all my scanned in pdf are now missing and replaced by small 179x256 72dpi images!

i havent moved the files in the database, ive tried to repair and it comes back with ******* errors found…then ******* errors not fixed or somethin alng those lines - help!!!

ive checked the database file and opened the package, my pdf’s are still there in the files folder.

Somehow my database has lost contact with my files?

the documents our paperless office and the file is approx 8GB - what can i do.

(Revert to backup is greyed out in devonthink, but ive had it set up to backup daily)

Well, I managed to figure out the problem. Devonthink was not the source of the problem, but rather a file management mess-up on my part.

I was importing the files into the database, but through a series of stupid maneuvers managed to delete the “Files” folder that was stored internally in the database.

That’s probably the consequence of the errors. If “Restore Backup” isn’t available, you might either restore backups from other discs/volumes (if available) or open the database package in the Finder and check if there’s a Backup folder inside.

ive checked the backup folder and theres 3 backups but only 1 file in each arent there supposed to be 10 in each?

Ive tried all 3 backups and when i open devonthink it shows no files at all, but still find errors.

All the pdf are in the files folder, it would appear that devonthink has lost ALL these file locations as no location is indicated in the file info box
Is there a way of re connecting the files folder with the database in 1 go - other than going through each individual pdf!!

Definitely. As DEVONthink doesn’t remove them on its own, something strange seems to be going on. How many database files are right inside the database package? If there’s also only one file, than that’s the reason for the errors.

Are the file permissions right? And is there enough space on the volume left?

weve got 350gb left on the server where the database is kept.

there 10 davonthink databases 1-10 & settings.plist & devonthink.lock +12 files and backup folders and a files folder.

in finder the file info states that permission are all unlocked and files are all read and writable.

What kind of server & filesystem do you use? DEVONthink tries to lock its database while it’s open (to prevent concurrent usage by several people) but not every server/filesystem supports this.

its an infrant readyNAS NV system - dont really know anymore than that. - (but its been working fine for the past 5 months)

We did have some difficulty the other day with devonthink trying to scansnap docs in - kept coming up with an error about database already in use. I think the admin staff had devonthink pro open and then scansnap was trying to open the same database with the office version. -( ive uninstalled pro and reinstalled only the office version after this.)

Anyway, Is there anyway i can reassign all the pdf files or is it back to an earlier backup??

It is definitely not a good idea to access a “shared” database through a file-server on Mac OS X because it can’t be guaranteed by the system that a file is locked exclusively for one client. So when multiple users access that database it is highly likely that files will get clobbered.

ok so thats the problems - any ideas on how to save our database.

i considered myself smacked on the hand!!

Using or fixing the damaged database isn’t recommended but the files should be still all there:

Just select the database package in the FInder, open the contextual menu, choose “Show Package Contents”. Now select the “Files” folder inside the package and copy (!) it to the desktop for example or anywhere outside of the package. This folder should contain all scanned files. Then use these files to create a new database.

Or just switch to an earlier backup if available.