PDF search Issue

Yesterday, I was in a pdf file (Devonthink’s reader) and using the search function. One of the search terms, GSTU, would produce about thirty occurences. This morning my hope was to continue with that same work. I opened up Devonthink, then downloaded and installed the new updated version after receiving a prompt. But now when I do the same search in the same pdf, GSTU, it only shows 1 occurence. I haven’t done anything different between yesterday and today (with the exception of installing the update). Any thoughts?

Try toggling the support for operators & wildcards in the Search inspector, does this make a difference?

No… tried toggling, every combination, and still get only 1 occurence. Also, I opened and close the pdf… all with the same result.

How many occurrences does Preview.app find?

Preview also shows only 1 occurence…

PDF Expert only shows 1 occurence…

Then I opened up the original that I still had on my desktop (so outside of Devonthink) and Preview showed 18, while PDF Expert showed 19 occurences.

Did you edit/annotate the PDF yesterday? Maybe it’s an issue of its text layer.

Actually, yes, I made one highlight. I highlighted one line, but it was across several tables, somewhere in the middle of the pdf.

How many occurrences are found after importing the original? And which version of macOS & DEVONthink is used?

When I import the original, 18 occurences are found.

I’m using macOS 12.2.1

DEVONthink version 3.8.4

Note: The current version of macOS Monterey is 12.4. We suggest you stay current with the operating system and our point releases.

Right… I don’t have the updates set to automatically install and It seems I’m always just a little behind in doing it.

But… I’m worried because my trusty Mid-2015 MacBook Pro 15’ will soon be dropped by Apple :neutral_face:

“The world is has moved on.”
~ Roland Deschain, The Gunslinger


1 Like

Yes, indeed!

1 Like