PDF thumbnail not updated after PDF edit

As the title says - Devonthink does not seem to update the PDF thumbnail after a PDF has been edited.

I cropped a PDF as the document was A5 whereas it was scanned as A4 - the excess blank space was removed. It opens fine as the cropped document. However, the thumbnail in Devonthink still shows the original with all the blank space, which looks messy and not as intended. How can I fix this? Thanks!

It should be automatically updated depending on Preferences > Media but you can create/update it on your own (see Data > Thumbnails menu).

Thanks for your reply cgrunenberg - but I had already tried that. I tried updating the thumbnail (which did nothing), then removing it and creating it again (which simply created the thumbnail as before, with the extra space).

Do you use the latest version (2.9.17)? Could you send the document to cgrunenberg - at - devon-technologies.com? This might be a bug. Thanks!


Yes I use 2.9.17.

There are many PDF files that have this issue. I have picked one and emailed it to you as requested. Keen to hear what you make of it!

As you can see in the below screenshot, if I open one of these files in Devonthink, it even shows the correct page but the incorrect page thumbnail!


Thanks again