PDF2RTFService 1.1

OS: 10.4.11
1.5Ghz PPC
1.25GB RAM

I apologies for the length of this request.

I really had no idea where to post this, and this seemed as broad a board as possible, so my apologies if I am grossly mistaken. I am having issues with the PDF2RTFService freeware…“thing”.

I say thing because I am not sure exactly how it works or what exactly a .service is. I followed the directions in the ReadMe file but I was unsuccessful in finding the service folder in /Users/username/library/ folder. Nor did creating a service folder and placing it in that work.

I even hunted down "CoreServices folder and put it there. I only left it there for a bit because it forced me to authenticate before telling me I didn’t have rights to the folder. I have taken it out since.

Supposedly, so the notes make it sound, if you install it correct you can open .pdf files in cocoa applications like pages and TextEdit. Well I don’t have Pages but I as all other Mac users have textedit. So I tried opening the PDF file in question there. All I got was gibberish. I am, as we speak, running the txt file of it through File Juicer, but frankly I’m not sure exactly what it is supposed to do I just found that it would convert .pdf to text. Alas that gave me unhelpful files and I fear putting the converted pdf to text folder here by just opening the .pdf in text edit and then placing that in File Juicer will reach the same results.

In the end I just want a cheap or free .pdf to text (anything editable) converter so I can make notes easier for School work.

thanks for reading my rant for anyone who got this far.

When you created a new folder at /Home/Library/ did you name it Services? That’s the proper name. If you then drag the file, “PDF2RTFService.service” into the “Services” folder it should work for you.

As the ReadMe notes, the file could also be stored in your boot volume’s /Library/Services/ folder, and would then work for all user accounts on the computer.

I just checked this service under Snow Leopard 10.6.2. I opened a couple of PDFs from TextEdit and it worked properly, producing files containing the rich text of the PDFs. The text looked fine. That said, there are some weird ‘flavors’ of PDF out there, some of which may produce strange-looking text.

Comment: If you work with a lot of text extracted from PDFs, you will wish you were running under Snow Leopard, as there are no longer hard line endings for each line of text.

Thanks Bill. That worked–kinda. I put the files in the wrong locations at first. Then I found /System/Library/Services. I put it there and tried to open the file in text edit. It ended up only opening the non .pdf part. The rest of the content was non-existant.

So I figured I would try with a different file. I tried a file that I got from google books. It was a Latin book that they scanned. Now I may not understand what should work for a .pdf converter and that these files I am trying to convert are too akin to pictures than editable text documents. The original I tried may be a scan, it is from an online scholarly journal aggregate through a university. The other as I said was from Google and is seemingly a scan. So as I said I may not understand what should and shouldn’t be “convertable.”

The other odd thing is that trying to do this caused that particular service to take up like 90+% of my CPU. It started the fan up and started getting really hot. Then my HDD space started shrinking. So I deleted all the other files I tried to make from File Juicer, I then deleted the file created by my first attempt and a couple of free apps I got thinking they might be useful (Onyx and some other one).

Anyway. Am I barking up the wrong tree? If anyone is curious I would be willing to email them the .pdf file to see if they can try their hand at it to see if it is even doable. Thanks again.

Not Boot Volume/System/Library/Services/. Wrong tree.

Text can only be extracted from a searchable PDF. An image-only PDF has no text — it’s just a picture.

I was afraid of that obvious fact. I was hoping that it somehow recognized the ink shapes or something. Doesn’t the Adobe ORC do something like that? Anyway, I see I am barking up the wrong tree unfortunately (not in terms of your aid, but in terms of my ends). Thanks Bill.