PDFs stopped importing

This is a new phenomenon, probably since the 10.4.9 update. I tried creating a test database and importing into that. Got a couple of successes, then failure again. Without this feature, DT Pro is virtually worthless to me, as it is a repository of hundreds of PDF files. It also seems to be intermittent, as I tried just now to recreate the failure window for this post, and two PDFs that failed did import. What’s up with this?
Here’s the console.log for a typical failure:

2007-04-01 12:29:51.877 DEVONthink Pro[558] openFile:storage:inGroup:groups:what::encoding:ignoreRichText:finderData:indexOnly:canCopy:download:contentType: (KBase):
connection timeout: did not receive reply

Any help would be appreciated. Thanks.

Have you installed ShapeShifter or another haxie? Or recently installed a third-party internet plugin or input manager?

I always recommend deleting the Adobe viewer plugin, as it still seems incompatible with PDFKit.

The first thing I tried was going to APE manager and putting DTPro on the Exclude list, although it played fine with them before. As far as I know, no other plugins have been installed recently.
I did once notify you some time ago that with ShapeShifter I was getting some bizarre behavior, the details of which escape me.

Even though I had disabled DTP in APE Manager, I tried disabling all haxies at restart. PDF import worked fine. I went into APE M and saw it was still on the Master Exclude list. Went to ShapeShifter and saw DT & DT Pro on the exlude list for that specific haxie. Upon examination, DT showed the icon in the exclude list, but DT Pro showed a document icon. I removed that, added the app (now showing the lovely Nautilus shell), restarted, and all seems to work fine now.
ShapeShifter definitely wreaks havoc with DT.

The problem is not that ShapeShifter directly affects DT Pro. Rather, ShapeShifter modifies the operating system and causes cascading memory errors. But DT Pro makes a great many calls to the operating system, and if there are problems with the operating system, errors will be generated.

When you install applications such as haxies that deliberately modify your computer’s operating system, you are making a “leap of faith” that your operating system will continue to perform according to the design specifications established and tested by Apple.

I’m afraid that our experience demonstrates that such faith is misplaced, and that we have seen OS errors tied to a number of haxies, most notably ShapeShifter. Putting DT Pro on ShapeShifter’s Exclude list seems to have temporarily fixed your problem with PDFs, but doesn’t protect your operating system from other code and memory errors that can “bite” you.

Personally, I keep my operating system very close to the stock code provided and tested by Apple. Even OS X has some bugs, but modifying OS X with applications that may also have bugs makes performance of the operating system less certain. Our experience with users who have installed ShapeShifter is that their computers become flaky. So I wouldn’t allow it on my computer. When I’m using an application and make a call to the OS, I want to be confident that the result will be appropriate, not erroneous.

I do know that you’re correct. I can live without almost all, but they’ll have to pry FruitMenu and WindowShade out of my cold, dead hands. I do appreciate the support and the advice.

OK, we don’t want to see your untimely demise, and I’ll keep my fingers crossed for your computer’s health. But be aware that in the past both Fruitmenu and WindowShade have ‘broken’ following OS X updates or upgrades, with resulting problems (even including networking problems, as I recall). So at the least, keep them updated. :slight_smile: