Persistent Syncing Issues and duplicated indexed items


I’ve had a lot of trouble with the syncing lately. After upgrading from DTPO to DT3 Pro, I opened all my old databases so they would be available to the new version and set up syncing via icloud.

Initially I had just noticed that I was moving a lot of the same files to their proper place, though I wasn’t 100% certain, maybe I had left them and the folder structure I had created to house them entirely within databases inbox and didn’t notice because the inbox was self-contained within the database itself as opposed to the new global inbox setup. idk.

What I do know is there is definitely something going on because now I’m noticing that I have to reselect some of my databases for syncing and that there these instances there is an additional database listed as being remote, if I open it it will take the place of the already existing local one.

I’m sure it’s probably a user error, but still, how do I fix this. How do I make sure I delete the correct database without losing my data?

On another, possibly related note I’m ending up with duplicate files and folder in several folders I had indexed. I believe this is because I may have created some of my sub-folder structure from within Devonthink after having indexed that folder, but I was under the impression that the new way indexing worked meant changes in DT transferred to Finder as well, or am I mistaken. If so, how would I fix this?

Sorry, I feel like that’s a lot, I’m appreciative of any assistance you could give me

I’m running the latest beta from the latest version of Mojave on a MacBook Air and iMac combination and they should be syncing via icloud.

Are your indexed files/folders located in cloud folders, e.g. iCloud Drive or Dropbox? In addition, is the option to duplicate files in case of conflicts (see Preferences > Sync) disabled?

Yes, the files/folders are in my documents folder, or on my desktop folder which are technically in iCloud Drive and no all my databases have been set to replace duplicates with the latest version of the file.

Are you able to successfully verify the sync store (see contextual menu in Preferences > Sync)? A screenshot of the issue(s) plus steps how to reproduce them (if known) would be appreciated.

Yes I’m able to verify database, both for the one that shows as being open or recently opened within devonthink as well as the remote one. I’ve tried to verify quickly and thoroughly

I’ve also noticed several general settings failing to stick, such as zoom text only as well as the option to open wikiLinks in a separate window, not sure if it’s at all related to the other issues I’ve been experiencing

Just tried to reproduce the preference issues but no issues. When exactly are these settings reset? After closing & reopening the preference panel or after relaunching the app?

After closing the preference panel

Which version of macOS, which system language and which version of DEVONthink 3 do you use?

Mojave 10.14.6 and the latest beta version of devonthink 3

I’m not sure I know what you mean by system language. English?

Weird. I couldn’t reproduce this using the same versions & language. The settings are the same even after relaunching the app.

Does that mean I broke it?

No, as long as the system works as expected it should be impossible for you to break anything. Are you able to reproduce this issue using a second, clean macOS user account (see System Preferences > Users & Groups)?

I don’t know, I’ve been trying to avoid reproducing it not doing so on another user account, sheesh…

I can try setting it up but what all would that entail? You’re probably going to have to walk me through this under the assumption that I’m a bit of a technotard with some of this stuff

And assuming I’m unable to reproduce it, what would that mean?

That something might be broken on your default account, e.g. DEVONthink’s preferences.

So then how would I fix that?

Hard to tell without having access to the system. You could try to delete the preferences first by entering this in the Terminal…

defaults delete com.devon-technologies.think3

…while DEVONthink 3 isn’t running.

Would I have to do this on just one of my computers or both of them?