Pinboard import script no longer works

I’m running DTPO and Yosemite. The Pinboard script no longer works, when you run it DTPO takes up 80-100% of my CPU and nothing happens. If you force quit the bookmarks appear to be there. It might be a Yosemite issue because it did work until recently.

Could this new behavior be because the script is not using the Pinboard token (Pinboard was going to start blocking some access using username/password)? I’m hoping this script can be fixed and maybe even given the option to use the token instead of username/password.

Bob Sica


It’s working fine for me, but you’re right to be concerned about the token issue. I’m surprised the script is still functional at all.

Thanks. I tried again today but same behaviour, the bookmarks are imported but DTPO freezes in some loop taking up most of the CPU. Force quit required.

Is this issue being addressed, I would like to re-integrate pinboard and DTPO? Would you please give me a status update?


I have some new information on this problem. I ran the Pinboard input script and waited until dtpo froze. I then went into activity monitor and killed “System Events”. DTPO then unfroze. I then verified my database and it was in good shape, no problems.

Does this new information help in fixing the problem with Pinboard import?