Please fix the Sorter running under Lion

The Sorter continues to give me problems. For a long time now, I haven’t been able to put it on the same side of my screen as the dock, and it keeps getting in my way in all other positions.

And now, under Lion, I keep getting the show/hide dialog for apps going to full screen, but this is happening without the app actually going into full screen. It might actually be a Mail problem, but sometimes when I open a mail message in a new window (not full screen), I get the dialog box. And sometimes when I try to drag a message out of program, I get the same message. I feel like I’ve gotten the notification with a drag action in other apps as well, but I can’t remember which ones it was. So again, maybe a Mail only problem, but it may be a larger issue.

So, needless to say, I’d love to see the sorter straightened out (both issues). It’s making my use of DTP more and more of a headache. Thanks.


Hi Doug

The issue with sorter not residing on top of the dock, which side is your dock positioned? What happens when you place the Sorter on that side?

Lion has introduced a number of false full screen notifications. To work around this it would be worth in the preferences to add Mail to Sorters list of full screen apps to ignore.


I’ve had some issues as well; I’ll try to keep track and repost. But it also happens to me without using fullscreen (I use two monitors and full screen in Lion is sort of a waste).

BTW, I have had a problem with Sorter creating a dead space on my second monitor off a MBP. It was positioned on the left of the MBP’s screen, and just to the left of that the virtual desktop extends on to my second monitor. Sorter would become the active window without appearing visible, and if I clicked in that area nothing would happen. If I moved around a rectangular area, I could find the edges and it was about the same size as the Sorter window. Quit Sorter, and the problem disappears. I moved the popup to the second monitor, and haven’t yet had a problem.


Hi Rob

Could you grab a screen shot of the dead space issue the next time you see it.


That’s the problem though: you don’t see anything, it’s just that clicks don’t seem to respond. A screen shot would just show a cursor hovering over a window. It happens on what seems to be the back side of the Devonthink tab if you’re using two monitors and have it positioned in between them, if you will. It doesn’t happen if it’s attached to the outside edge of the virtual desktop space.


I’m also seeing this issue under Snow Leopard. It’s a little bit difficult to explain. I have two monitors as well, and I’ve always had the Sorter tab positioned on left monitor at the right edge of the screen. Now on my right monitor, if I try to click NEAR the left edge of the screen, and at about the same height the Sorter tab is (on the other screen), the click does not go to the window that you are seeing there but instead seems like the Sorter got the focus.

And the same thing happens if you move the Sorter to the right screen and position it at the left edge of the screen. Trying to click somewhere at right edge of the left screen will send the click to the Sorter and the window where you expected to click will lose focus.

All is well if you move the Sorter tab to an edge that does not have an adjacent screen, i.e. the left edge of the left screen or the right edge of the right screen.

This started happening right after updating to 2.2.1

Thanks for the explanation.

There is an issue on the latest version of Snow leopard where mouse clicks on a hidden part of the window are not correctly passed to the window below. This could be related to the problem you are experiencing. I will take a look to see if I can reproduce it.


I am having another issue with the sorter in Snow Leopard. I have 8 items in queue that aren’t transferring to a database that’s open.

When I start DTPO, I get this error message:
The operation couldn’t be completed. Name is not set for the dropped data file!

I’ve tried restarting the app and sorter multiple times. Looking forward to hearing your advice.


Hi Jeff

Slightly puzzled by that as a name is automatically generated for the item if one isn’t provided. What type of documents are they?


They’re emails dropped from Apple Mail.


Hi jeff

I don’t have an immediate answer to transferring the files to DEVONThink.

If you still have your emails in Apple mail, I would remove the 8 queued items in Sorter by ctrl+click on the Sorter folder and selecting “Remove Item”. It would be worth doing this with DEVONThink open as it may only be one of the emails that is causing the problem.

I have added a fixed for this issue to be included in the next update.


my issue with Sorter under Lion (10.7.1) is that it no longer loads… it is set to start up, appears in Activity Monitor where I can quit it and then load it again where it reappears, but is nowhere to be found… some of the time… then it appears after a series of killing it off and then restarting it…

if it is not having that problem and it up and going where it should be it then gets the error message when dropping times into it:

up until Lion loved Sorter and used it hundreds of times a day!!!

Hi Trevor

It would be worth deleting the Sorters preference file.

In finder if you select the menu Go->Go To Folder, type ~/Library/Preferences and press Go. If you are running DT Pro delete the file com.devon-technologies.think-sorter.plist, otherwise delete the file com.devon-technologies.thinkPersonal-sorter.plist.

I will have a look at possible causes of the other error you were getting.

Thanks for that Alan

I was sure I went through deleting all my prefs a week or so ago which fixed the problem for a while only to return… but this has fixed it so I will keep an eye on it to see if it goes haywire again…

another thing… I was sure I saw somewhere in DTpro the ability to check boxes for the groups one wanted to have in Sorter rather than having to drag them from the DTpro into it… maybe I was mistaken… just when I drag a group from DTpro to the sorter it gets a blue folder icon rather than the brown ones which makes it look messy in a way… but this happened before Lion so is not an issue for this thread really :slight_smile:

great to see an Aussie on the Devon team :smiley:

Hi Trevor

I don’t know of a way other than dragging folder from DT to Sorter.

The colour of the folder icon in the Sorter should be the same colour as the icon in DT. I will check to see why you may be getting a different colour.


the attached… if I got the attaching bit right on here :slight_smile: … shows what I mean… the blue folder is one I just dragged into the Sorter from DTpro
Screen Shot 2011-08-24 at 11.38.57 PM.png

The blue icon indicates that the folder ‘Computer’ has tagging disabled. You will notice that the gold folders also have a tag in the icon, indicating that they have tagging enabled. You should see the same colors in the database, unless you have set the General>Appearance>Colorize icons with labels to checked, in which case all groups are blue. The Sorter does not observe this preference, so you’ll need to enable tagging for the Computer group (Show Info, uncheck 'Exclude from tagging) if it is important that all groups in the Sorter be the same color.

I just wanted to mention that I’m also experiencing the “dead space” issue. I’m running DTPO 2.2.1 on 10.7.1 with two monitors. When the Sorter is closed and its tab is on the edge of either display where it abuts the other one, there’s a dead area the same size as the Sorter on the adjacent display. It’s as though it has “slid in” to the display next door and has become invisible; clicks in that area just don’t register. I would be very happy to see this problem disappear.

I’ve problems with the sorter as well-
For instance while using the Preview app for viewing documents (not full screen); the sorter asks whether I want to hide the sorter while in full screen. I click okay.
The consequence thereof is that when I drag a document from Preview (via the small icon in window next next to the name of the document), the sorter hides - like it is playing an annoying game with me.


Because of the sorter problem in Lion I don’t want to start it at login. But the checkbox in the preferences will not save it’s setting. When I uncheck it and go to another preference tab and than back to the sorter tab again, it is still checked. Is there a way to fix this?