Possible Bug: Group assignment is lost after OCR

Because OCR takes so long I tried to follow this process:

I checked “move the original document to trash after OCR” in the preferences.

  1. Scan documents as PDF and move them to inbox without running OCR.
  2. Add tags and sort the PDFs into groups.
  3. List all PDFs which are not searchable using the intelligent group template “PDF not searchable”.
  4. Mark all PDFs in the list and run “convert to searchable PDF”

After OCR processing is finished, however, the group assignment is lost. I discovered this when some newly created groups were empty again after OCR. So I had to search for these unassigned documents and sort them to the respective groups again.

Tags are not lost though. Is this intended?

What do you mean “the group assignment is lost” ?

I draw the pdf to a group. The PDF is the only document in that group. Then I run OCR on that PDF.

After that the group is empty.

I have to search for the PDF and draw it to the group again.