Preferences - Java and animations

In the Web Preferences, there are three settings that are problematic for me.

Enable Java re-checks itself. It doesn’t matter whether I quit the programme, delete the preferences, reboot the computer, whatever, this setting is always checked. This is new to DTPO2.

The Animate images and Loop animation of images don’t seem to do anything (except perhaps, to mock me). Animated gifs always loop forever. Again, deleting preferences, flushing cache, quitting, etc… have zero effect on this. It was that way in earlier versions of DTP as well.

Is there something that can be done to make these minor irritants function properly?


p.s. The Sorter has similar issues. None of the settings for it seem to work. I use an external display and it attaches itself to different screen edges, but not in the manner which I’d prefer. I generally just manually remove it from the Login Items because not working at all feels better than when misbehaves. But I’d be satisfied if the Start Sorter at login setting worked.

As the WebKit is handling these options and as they’re working as expected over here, a third-party extension, haxies or invalid permissions might cause the troubles. Does this happen using a new user account too? Does deleting ~/Library/Preferences/com.devon-technologies.thinkpro2.plist make any difference? Which version of Mac OS X/Safari do you use?

Okay. That’s weird – partial success. I’ve deleted the prefs many times but now it is working for the Java pref. It remains unchecked, even after a restart.

The animations persist. The Sorter still launches but I can deal with that.

This was a fresh install on a brand new machine (MBP i7 running 10.6.4). The one difference from the last time that I deleted the prefs was that I’ve since upgraded Safari from the most recent 4.0.x to 5.0.

The only ‘extensions’ that I have are Perian 1.2.1, Growl 1.2 and RazerPRO 1.6.8 (mouse).

All the problems persisted for a long time on a G4 Powerbook running various versions of Tiger and Leopard (I update routinely) and DTP 1.5.3. It was because the problem persisted on a new machine (with DTPO2 as a clean install, even a new database) that I wrote this post. No prefs were brought over from the old machine.

I will try the new user account to see if there is any difference regarding the animations and sorter prefs.


p.s. One other minor change after this… The folder colour changed to yellow for folders without the ‘exclude from tagging’ option checked. All folders (except smart) were blue before.

Could you send me an example URL containing animated images? Thanks!

Does removing the Sorter from your login items (see System Preferences > Users) fix the problem?

That’s correct. Only groups excluded from tagging (see Info panel or Database Properties panel to exclude all groups) are blue, the other ones are used for tagging and are therefore yellow.

Does removing the Sorter from your login items (see System Preferences > Users) fix the problem?

It fixed it for one restart cycle. After another restart, it was back in the System Preferences > Accounts (10.6). In DTPO’s own prefs, Availability is unchecked (but Visibility is checked).

I don’t know if this means anything but after this changing of preferences and deleting plist, there were some DTPO files in the Trash after restart. DEVONMailConduit-SnowLeopard.mailbundle and its contents, and in a Recovered Files folder a ‘.growlRegDICT’ document. After emptying the trash, the next restart had two Recovered Files in the Trash with names like ‘dftmpKMAOJFIMqkkkkkkk--------’.

This seems to be a bug of the WebKit of Safari 5 as the preferences are ignored.

Did you use Help > Install Add-ons and was the installation of the Sorter checked?

The RecoveredFiles folder is created by Mac OS X, not by DEVONthink.

I think that it is triggered by the combination of DT and Growl. I will try un/re-installing them to see what happens. Thanks.

Thanks again for all your help.