"Prefix while typing" cannot be de-activated

I am using DevonThink Pro 2.0.9 on 10.6.7 and I cannot de-activate the “Prefix while typing” function in the quick search pane.
The option is de-selected, however searching always starts the moment I press the first keys.

You can see it here: http://www.youtube.com/watch?v=YlfecEowVe4

Any idea what is going wrong here? It is just a minor issue, but maybe there is an easy fix?

This option toggles only the handling of the search term but doesn’t stop searching while typing (you could use Tools > Search instead).

If the option is activated, then the last entered word is handled like word*, meaning that each word having this prefix is found. Without this option, only the entered word is found.