Preserve Quote Levels in imported emails?

Hmm, it seems that when I add email messages to DTP from Apple Mail, using the "Add Message(s) to DEVONthink script, quote levels are not preserved. So an email that includes quoted text from a prior message gets flattened into totally plain text, without any way to tell what text was from the reply and what was from the older message! Needless to say, this is highly undesirable.

Is there a way to correct this problem? Maybe a different way to add emails to DTP that preserves quote level? Maybe some import setting somewhere?

If there is no “sane” quoting information present, then it won’t quote. If you can “Save As…” that message as “Raw Message Source” in Mail and email that file to I can take a look at it.

Okay, thanks. I just sent a test email to that address, followed by an email with the rtf file of the test email attached. The test email should have 4 quotation levels. I don’t know what “‘sane’ quoting information” is. I’m pretty sure I’m using mostly the default settings in Apple’s

Saving the test email into DTP (using the script mentioned above) results in a totally flat text file with no indication of quote level.