Print-saving to PDF takes a very long time

Using the “Save PDF to DevonThink” feature* in the print dialog takes a long time, usually in the region of 1-2 minutes per PDF.

Can this be speeded up? If I have to save 20 webpages it takes me 2 minutes to do and a half an hour wait for them to appear in DT.

  • I use this most of the time because the Safari “Clip to DevonThink” extension is too unpredictable with its rendering and session handling. It would be nice if this worked, but that’s another topic.

This is simply an Automator workflow. Does it pesist after a machine reboot? Do you have low resources or an older machine?

Thanks for getting back to me. My machine is generally pretty quick, MacBook Pro, 8GB, no issues on performance. CPU monitor indicates boredom, ditto with disk & network.

This persists through reboots. It used to be quick, but been like this for so long I can’t even remember when it slowed down. As there was no load and the machine is otherwise perfectly useable, I assumed some kind of delay was built in for some reason. Occasionally it gets a bit bothersome (like today), so I thought I’d ask here.

It’s actually just an alias and should work instantaneously.

Thanks for the feedback. I’ve done more detailed research and it seems to be a consistent 1:30s delay. I discovered another unwanted side-effect: if I ‘queue up’ outputs the source URLs get muddled.

I rebooted my machine. Started Safari & DTPO.
Saved the APOD page using the Save option in the print dialog.
Waited for it to appear in DTPO, 1m30s.
Saved it again from Safari, started stopwatch.
Without waiting I went to Google and saved that too.
APOD appeared 1:30 after saving. Google 1:30 after that.

But the second APOD had Google’s URL:
Screen Shot 2015-03-31 at 15.57.09.png

So what it appears to do is delay for 1:30 and then pull the URL from the currently open Safari window.

Could you please launch Apple’s Activity Monitor application (see Applications > Utilities), choose DEVONthink in the list of processes, click the “Sample” button in the toolbar (after using the Save to DEVONthink Pro service but before it’s actually added) and send us the result? Thanks in advance!

OK solved it.
If the printer is switched off (which mine usually is), it sits for 90 seconds, even though I’m not printing anything. If I switch on the printer it pops into DT straight away.
I changed it to use AirPrint and now it works even with the printer switched off.

Edit: Cancel that, the AirPrint trick only worked briefly before it reverted to the delayed behaviour. As soon as I switched the printer back on a whole batch of documents I’d been saving suddenly appeared in DT.