Print to Devonthink is gone... how do I get it back?

For some reason the “print to Devonthink” option in the systems Print Dialogue is gone…
I am on macOS Monterey (12.5) and have the latest Devonthink Pro version (3.8.5).

I tried to reinstall the PDF Services several times with no luck…

And this is what my “print to” options look like:

image

What am I missing?

Have you given DEVONthink Full Disk Access in System Preferences > Security & Privacy > Privacy?

hm well for some reason Devonthink did not have full Disk access… but it definitely had it in the past.

But anyhow… I gave it full Disk access again/ restarted Devonthink and restarted Preview… still no option for saving to Devonthink.

Did you also go back and install PDF Services again; a step which probably previously failed due to inadequate access?

Yes I did,

  • What do you see in ~/Library/PDF Services?

  • Does the issue persist after rebooting the machine, then trying the install again>

image

I did not yet restart but will do soon and report if the issue still persists or not

Unfortunately restart and installing the PDF service again did not help :frowning:

Do you see the same issue when booting into safe mode or using another macOS account?

So I tried to start in safe mode but my intel macbook just wont… holding the shift key at startup just didn’t do the trick… I also tried to reset NVRAM … no success…

So I created a new user and installed the pdf service and with the new user it works… But my real user still can’t “print to devonthink” …

1 Like

Have you tried deleting the service from here, restarting and then reinstalling? I’m not too hopeful, but it would be my next step.

Well I did not restart in between, but that did not help either :frowning:

Go into the user Library and check the permissions on the PDF Services folder.

oh I totally forgot that the PDF Services are symlinked to dropbox… could this be an issue?
I use a GitHub - lra/mackup: Keep your application settings in sync (OS X/Linux) for keeping app settings sync between machines.

But the permissions look fine:

Could be. see Symlinks in Dropbox | Dropbox Help

remove the symlink and use real files and see if it works.

2 Likes

yep that was the issue…
Thanks to everyone for the help!

1 Like

Good call @rmschne :smiley:

Hey. When my mini refused to start in safe mode it seemed to be a bad sign. It went in to the MacMan store (now Fixio) Brighton for various misbehaviours like stalling in some apps - and the tech told me that the reason for my inability to use safe mode was probably down to my SSD failing. (A crucial). I now have a Samsung in there.
No Utility was seeing disk issues and smart status was OK.
Strange
You may like to check.

1 Like

and the tech told me that the reason for my inability to use safe mode was probably down to my SSD failing. (A crucial).

Yikes! That’s an ugly thing to have to hear but we’re glad you have a new drive in place.

Was there some error or strange behavior when you tried to boot in safe mode?
Because in my case there isn’t. It just starts in normal mode without any indication that he tried to boot in safe mode…