Problem: capturing content from Safari via Sorter brings up empty file in DT3


I have problems getting content from Safari into DT3. I import via the Sorter (menu item), but the file seems empty. Upon closer inspection it seems that text is there, but it is invisible (if I try to mark it with the mouse, something is being marked; if I copy and paste it into a Drafts document. text appears). So apparently white text on white background is the problem.

When I take the same webpage and print it to a pdf (via the Mac OS print dialogue) and import it directly into DT3, no problems arise.

This is a bit difficult to describe – hence I try to attach two files showing the problem. I’d be grateful for any help as this complicates use of DT3 very much for me. Initially I thought this might have to do with my old MBP which ran Mojave, but having now switched to the new MBP under Catalina, it persists.

Any help greatly appreciated!

AndreasCovid UK- scientists at loggerheads over approach to new restrictions - Science - The Guardian 2.pdf (81.0 KB) Covid UK- scientists at loggerheads over approach to new restrictions - Science - The Guardian.pdf (91.6 KB)

How do you exactly import the item? From a website? What’s its URL and which settings did you use?

Thanks for the quick reply, Christian!

The URL is

I click on the menu item (the little Devon symbol), choose the Safari symbol and use Format PDF (Paginiert). I import it to the Inbox.

Any other settings that you need?

Hmm… I’m not seeing an issue with that URL.

It has nothing to do with that specific URL. I can send you two other files where the same problem applies. I am puzzled, too! Here, the file seems to have no content at all…


Brexit- JP Morgan verlagert 200 Milliarden Euro nach Frankfurt 2.pdf (221.0 KB) Brexit- JP Morgan verlagert 200 Milliarden Euro nach Frankfurt.pdf (929 Bytes)

  • Are you running DEVONthink 3.5.2?
  • Does this persist after rebooting the machine?

1.) Yes.
2.) I will give it another try later (off to a videoconference in two minutes), but that problem even survived a change of MacBooks, so I guess the answer will be yes.

The URL I got a blank PDF from but this could be due to conetnt being behind a paywall.

Have you tried accessing the bookmark in DEVONthink and clipping it from there?

Trying to access the page within DT3 (after entering my credentials) gives me a “Too many HTTP redirections” error.

But trying it with a FAZ page that is not behind the paywall gives the same problem (see attached file).

With that URL ( I tested what you suggested (accessing it as a bookmark and then clipping it from there) it works. But: that is much more complicated! Could you kindly try whether for you this works in just one go? That would still indicate (as did the test with the page from the Guardian) that there is a problem – and I would like to hunt that down!

Thanks for your help and any suggestions!
Virologe Drosten- „Pandemie wird jetzt erst richtig losgehen“.pdf (929 Bytes)

It does persist after rebooting the machine.
It also happened on my previous MacBook Pro running Mojave, but only from time to time.
What can I do to isolate the causes as it seems to be a specific problem here rather than a general one?

Did you use the clutter-free option?

Sorry for late reply, I was away for a few days.
No, I did not use the „clutter-free“ option.
Thanks for helping find the problem - let me know if I can provide more information about my setup!

These are two different but site-specific issues of the WebKit framework, unfortunately it wasn’t possible so far to work around them. Therefore the best option is to print the page to DEVONthink.

So do I understand correctly that I am just unlucky in the choice of sites? Both FAZ and Guardian did work well back with with DTPO 2 – am I therefore right to assume that something must have changed on the software side in DT3?

Perhaps FAZ and/or Guardian changed something? Web site designers sometimes go over the top with complexity to make it “look good”. Their frequency of change is probably often.

Clipping is basically still the same but it’s of course possible that the sites changed and/or that an update of macOS and its WebKit framework introduced this issue.

I’ve had the same problem since I updated the last time…except the export doesn’t show up as blank in my database, but as a bookmark (web location) regardless of which setting I use, in particular a paginated PDF. Always a bookmark. Driving me bonkers. Any website. I’m still on Mojave using DT3.5.2.

I rebooted just last week. The behavior is the same. I saw something in the thread above that hinted perhaps it is a paywall thing, but I can’t even save as a PDF using the Sorter (goes in as a bookmark).

If you are consistently getting bookmarks captured, reboot again and see if the issues persists.

1 Like