Problem linking to Bookends

Using the File|Import|References from Bookends option I have created RTF files corresponding to Bookends references. These contain a Bookends URL of the form bookends:// My problem is that the URL is no longer working and the problem seems to be that, somehow, the Default app for opening such links has got changed to “Bookends marooned files app” which is no good. If I right click on the URL in the side panel, and go “Open with” I can select “Bookends,” but how can I reset “Bookends” as the default option so I can simply double-click the link?

the Default app for opening such links has got changed to “Bookends marooned files app” which is no good.]

It’s unclear what you’re describing here. Please provide more information, or better yet, screen captures.

This is the link you see when looking at the RTF created by importing from Bookends.


If I click on the link, it is not opened in BE as it should be.

If I go across to the sidebar on the right (excuse me if this is not the right terminology)

I see the link in the URL field.

I cannot get a screenshot of this, but if I right click on the URL, and click on “Open with” I see a choice of two apps, “Bookends marooned (default)” and “”. If I do the same on my laptop, I see only I haven’t a clue how it got like this, and I have no idea whether it is a DTP issue or a Mac OS/Bookends issue.

Did you update Bookrends recently?

And you can screen capture by opening the contextual menu, getting your hand off the mouse or trackpad, and pressing Command-Shift-3.

I updated BE AFTER the problem arose to see whether this solved the problem, but it made no difference.


Small clip of the screen to keep the file small. Note that my previous two screen grabs were with different references, hence the different URLs.

  • Have you emptied your Mac’s trash?
    • If do, have you rebooted?

PS: That’s from the operating system, not from DEVONthink.

Thanks. I shall try rebooting and contact Bookends support if that does not solve the problem.

Rebooting solved the problem in that clicking or rather double clicking on the URLs does what it is meant to, though it still says the same for the default app.

I feel embarrassed about not thinking of this earlier. Had it been Windows, my first instinct would have been to reboot, but I have got out of that way of thinking since using a Mac!

No worries!

Hmm… I’m not seeing an Open With menu when Control-clicking the URL in the Generic Info inspector. :thinking:

As I think I said, I do not see this on my laptop (M2 MacBook Pro), only on my Mini (Intel). When you said it was not a DTP issue, I asked Jon Ashwell, and he said that the OS is, for some unknown reason, dragging up some old app name but that provided that it points to the right package this should not matter and I should be able to ignore it. That seems to be right, at least following the reboot that you advised me to do, which appears to have cured the problem. Maybe upgrading to a new machine, as I hope to do soon, will mean the “Open with” option vanishes!

Thanks again for your advice. I must repeat to myself: “Even with a Mac, if in doubt, try rebooting.”

1 Like