Problem with right button

Hi to all,
I’m using Dtpro 2.0 from one month. From two days i have a strange behaviour using my logiteck mouse: In Dt and only in Dt, my right button don’t works. :cry:
I have searched for a solution in this forum but there isn’t any report about this bug. A little help please.
Thanks in advance.

I have to be more clear.
The right click only select the word when in editing and select records only when in record view but don’t obtain any right button menu.

I have no idea, other than to suggest that the right click command issued by the Logitech mouse has been taken over either by a command in DT 2 or by a keyboard shortcut that you have defined.

Does your Logitech allow variations of command assignments? Does the standard OS X keyboard shortcut for right click, Command-click, work on your computer?

Note that Command-click has contextual variations. For example, if you Command-click on a link within a document or browser view, the result will be to open the linked document in a new Tab.

Anyone else experiencing a similar problem?

Thanks for the help

I haven’t found solution yet.
Not only the righ button doesn’t work, also the ctrl click and the douple tab on my macbook doesn’t.

<<Does your Logitech allow variations of command assignments? Does the standard OS X keyboard shortcut for right click, Command-click, work on your computer?>>

Yes, it work for all the applications.

I am going to make a new installation of dtpro, hope this will solve the problem


I have tried to install again dtpro in order to solve the problem but nothing yet, the right button behaviour in edit mode and in record mode doesn’t change at all.
Maybe put the application in the thash is not enough. Maybe i have to delete some configuration file not in the application folder, please help. There are some very usefull contestual menus that i cannot use.
Is possible that i am the only one experimenting this tedious inconvenient?

I would start by creating a temporary new account and see if it works there. Then you know if it is the DT or the mouse driver. If it doesn’t work disable the Logitech software and see if that makes a difference. That helps to locate where the problem is.

I have tried this. Also with a new account i cannot obtain the contextual menù. I don’t think the problem is the mouse, doesn’t work neither the trackpad ctrl click. It seem that for devonthink and only for devonthink the contestual menus are disabilitated.
Thanks fo the interest, hope in another help.


Just to chime in here, I am also having this problem with a Logitech Revolution mouse. So Paolo isn’t alone.


OK, cancel that. Turns out I was having the problem because I was clicking on a link in an email imported from Apple Mail. See viewtopic.php?f=3&t=7354#p34083. When I converted the email to text and right-clicked on the link I was able to get the contextual menu.


Oooh, what a beatiful program would be DevonthinkPro with a contextual menu. This would contain a useful command like this: “Replicate to folder” or in edit context perhaps a command like “copy” or even “past”.
But i have to live in a real world. Maybe in the next release.
I love so much this program that i can wait.

I have tried all.

Yesterday i trashed the application with appcleaner, an utility that erase all the files associated with a program when you use it. In the list of the eliminated files was also some configuration files.
Then i installed the last upgrade of mac osx.
After this i rebooted the mac, and launched the installation pack of Dtpro2.X, i was sure the promblem was going to solve.
Launched the program, the contextual menu didn’t appear.

The last solution can be only to format the harddrive again. But it seem too radical.

I really cannot believe i am the only one with this problem. In medicine when a man has a very rare illness, the reserchers doesn’t investigates on it for economic reasons. The same could be for this issue.

Dthink gurus, please, devolve some of your attenction to this unlucky user.


I have the same issue on my MacPro with a logitech mouse. Everything works fine on my PowerBook G4 with the same DT preferences set.

Have you tried on the some machine to work without the logiteck mouse? I don’t think the mouse is the reason.
I cannot obtain cont.menus with or without it, also using ctrl click from the trackpad.
Anyway, happy i’m not alone, maybe now the developers will do something about this.

I’ll hazard a guess as to the cause of the problem.

Logitech is now using an Unsanity hack involved in an Input Managers plugin, LCC Scroll Enhancer Loader/LCC Scroll Enhancer Loader.bundle/Contents/MacOS/LCC Scroll Enhancer Loader.

I’ve seen a number of reports on the Internet about OS X instability problems resulting from this software. (Google “LCC Scroll Enhancer”.)

Suggestion: remove this plugin and restart the computer (you could retain a compressed copy of the plugin on your Desktop). Does your problem go away?

I thank you for the try.
I have looked for this pluggin on my computer but haven’t found it. I never installed any pluggin or logiteck software on my mac.
I think the only solution is to install leopard again. After all it can be a good occasion to clean the hard drive and put some order on my stuffs.
Anyway thanks again. I don’t think this an important issue to solve for the developers because it’s a very rare case that occoured to me and just another one user as i know.

I have exactly the same problem with DevonThink Pro Office and it is a big issue!

I’m not quite sure when it started, I think it was with Beta 5. I have not tried to downgrade.

Equipment: MacBook Pro and, interestingly, also an external Logitech mouse!

I had the Logitech software installed but uninstalling it did not make a difference (it remains uninstalled). DevonThink behaves as if I did not press the right mouse button at all. Touchpad Ctrl-Mousebutton does not work either :frowning:. No other software shows this behaviour. I am using Firefox as I write these lines and pressing the right mouse button works just fine. Switching over to Devonthink and - no reaction…

I am using a couple of add-ons such as Controller-Mate but - as I say - there is no issue with other software…

Now, I know this would be extremely hard to get rid of for you guys as you can’t reciprocate the error but it is a major pain in the *ss for me! It basically makes the suite useless…

Any ideas?