Problem with RTF encoding

I’ve tried to search the solution in the forum but was unable to find it.
It seems cyrillic characters doesn’t work in Devonthink’s RTF files at all.

For example I’ve tried to create a new RTF file and entered some russian sentence there:
http://macradar.ru/temp/rtf-russian1.png

After that I’ve saved the file and closed it. And then opened again:
http://macradar.ru/temp/rtf-russian2.png

Same happens when I’ve tried to export russian text entered in textedit.

I’ve tried to play with Encoding listbox in import preferences pane but it changes nothing.

please help

Which version do you use?

It is 1.5

Could you please post an example text so that I’m able to check this over here? Thank you!

вот пример русского текста

also you can copy anything from my macradar.ru - I’ve just tried that and it makes the same effect.

Seems that the RTF files created by Mac OS X 10.5 depend on the system language. Your examples are working fine on western systems but we’ll fix this in the next maintenance release.

Thanks a lot for your help.
When aproximately will be the next maintenance release?

Maybe this month but no promises. In the meantime you could use English as the system language.