Problem with syc hanging and crashing DT


I have setup a WEBDAV server to sync databases. I have synced my Macbook to the Webdav OK. When I then Import this DB onto my iMac, half way through it hangs on a 2Mb jpeg file. Just says its importing this file and gets stuck on it. So I then click to close this sync, and Devonthink crashes.

Then I have two more issues:-

  1. The Webdav backup is “in use” and I have to wait a while before I can access it again, and

  2. If I delete the offending file from the source computer database, re-sync. then sync again on the second computer, it still tried to import this file, even though I deleted it from the source and synced it. So it should not exist but it seems it does.


Another issue is… due to the above I tried syncing with a Local Direct connection. That was successful. When I then go to sync with the remote connection, which is unchanged and so should be identical to the local one, I get this:

“There are significant differences between the local database and the remote store. More than 10% of the records in the local database and remote store will be changed.”

But as stated they should be identical.

I have deleted the file on both computers, I have cleared all caches, there is no existence of the jpeg file on the machines, I have syned the Macbook to WEBDAV (it finished abruptly to be honest I wonder if thats another issue), and when I go to sync on the othe rmachine it still insists on trying to download the problematic file (a 2Mb jpeg) and hangs.

It seems I cannot get rid of the problematic file and it is stopping sync working.


I had to create a new Name for the sync, so in effect start again, in order to remove the offending file from the sync.