Query regarding the shortcuts for the Mail.app plugins?

Hello all – would appreciate confirmation on whether this is an issue my side, or if this is expected?

Over in Mail.app – the shortcut for adding a mailbox to DT3, is set to Shift+Ctrl+Opt+Cmd+M >> essentially therefore, the M + Hyper key.
The shortcut for adding a message to DT3, is then Ctrl+Opt+Cmd+M, therefore the same as above sans the Shift key.

How do I change these?
I would prefer the message option to have the Hyper key shortcut, since I use this far more frequently.

What I have tried:

Over in Preferences/Keyboard/Shortcuts/App Shortcuts, Mail.app is not listed, so it does not appear as if I allocated these shortcuts, which I am fairly certain I did.
This appears to be the core issue – without it being listed here, I cannot change it.

I disabled/enabled the Plug-in under the Mail.app preferences, with no change – other than having the menu items disappear/reappear in the menus.
Quitting/restarting Mail.app did nothing either, nor did restarting my system…

Running macOS 10.15.5 (Catalina) and DT3.5.1.

Any suggestions?

Emacs user?

The times where Apple’s UI was easy to understand are unfortunately long gone. I append a screenshot that shows how to proceed

Preferences/Keyboard/Shortcuts/App Shortcuts is the right place. Then click on the plus sign below the right list view. That will open the dialog shown at the top of the screenshot.

And there you can select “Mail” from the installed applications.

At least you do not have to wear a wizzard’s hat and dance around the computer while doing that :wink:

Thanks – I appreciate the detailed help!

But herein the dilemma – the shortcuts “exist” already inside Mail.app – but Mail.app is NOT one of the apps listed under the Preferences menu.
So, even where I add Mail.app, and then add the shortcuts using the new-fangled approach [ Mailbox->Add to DEVONthink 3], nothing changes.

It’s as if the plug-in is not being ‘recognised’ by the system shortcuts, and so cannot be changed?

I’m not sure that I understand what you’re saying. I’m not even sure how these shortcuts got into your preferences app – I don’t see them here (but e.g. in Mail’s “Message->Add To DEVONthink 3” menu). To me, it looks as if someone (who?) had duplicated all the app settings into the preferences. Which is weird.

Be that as it may: Did you try clicking into the definition? If I do that, I can change it.

All this is, BTW, not related to DT3 in any way. You can read about the preferences settings here, for example. Google will certainly reveal more information on “Mac OS define keyboard shortcuts for apps”

I added them after the fact, into Preferences. As mentioned, they weren’t there initially, which is what had me confused.

After adding them into Preferences (as in my screenshot) — no change is made. The two Mail shortcuts for Devonthink 3 stay the same — so I cannot work out how one would change/remove them.

Edit: To be clear, my understanding is that — unless it is an pre-existing app/system shortcut — adding that app into the Preferences/Shortcut pane, is the way one adds/changes/removes user-shortcuts to an application menu.

Which is why I’m stumped. Since I presumably added those shortcuts at some point, why is Mail.app not listed under the Preferences pane — and when added, why is nothing changed in the Mail.app?

Will open a ticket with Support.

I can’t say that I understand

  • what you did (changed the shortcuts for two menu entries in Mail.app?)
  • what you want to do (change the same two shortcuts?)
  • what you tried to do to achieve this goal (did you even read my last post? Click on your shortcut definition? Type in your new definition there?)
  • what is not working (mail.app not visible in preferences? Where? While your screenshot shows it to appear at least in the shortcut section?)

I wouldn’t get my hopes up that DT’s support can do anything about that. It is purely an Mac OS matter. Did you even follow the link in my last post?

I have just deleted a monumental reply, since computers occasionally seem to have a habit of making a fool of the user!

Somewhere between my reply with screengrab above, and now – possibly as a result of quitting and restarting Mail.app a few times, the issue has been resolved.

The changed shortcut (to Message->Add to DEVONTHINK 3) finally pulled across, and is now reflected in Mail.app.
Weirdly, the ‘test’ shortcut I set up above (to Mailbox->Add to DEVONTHINK 3) did not pull across – and instead, simply left the shortcut blank, which is what I wanted.
I have now removed it from the Preferences/Shortcuts/App Shortcuts pane completely, since I don’t want it to have one at all.

Regardless, thank you for trying to assist.
I do know how to add shortcuts (as confirmed in your link), as I have with many of my existing apps – but today, this was not behaving as expected, and then it simply fixed itself… Go figure!

Ok. Getting a bit ridiculous now. After quitting/restarting Mail.app, the original two shortcuts, that I wanted to remove/change, are back… Looks like I will be filing a Support ticket in any event… :tired_face: