Question about Linking & Sheets

I am thinking of using a Sheet to help me organize the courses I have bought over the years and am working on. I created a “group” for Courses (1 in the screenshot below), then a sheet within the top-level of the group (2 in the screenshot below) and then added connections to a course in the sheet. However, I can’t seem to click on the link to then navigate to the linked item. Any ideas?

Note - I realize that a TOC created through DT is likely easier, however, it doesn’t seem to keep my grouped items within their nested groups (i.e. everything I selected within the courses folder was left- aligned, not indented within year or course groups), so I decided this might work better for me.
Thank you for your help!

I also tried by creating a link field, but the link isn’t clickable?

Also note, Command + click doesn’t work (here’s a brief screencast video)

(Screencast video showing Cmd & click on Mac not working to launch link)

A table of contents file will be created in the same group if the selected files are in the same location.
If they’re not, it will be created in the root of the database.

Try Command or Shift-Command-clicking the link.

Thank you! Unfortunately no luck with either commands.

Do the files exist?
Copy the link. Paste it into Safari’s address bar, and see if it opens the expected file.

Yes. Pasted into Safari, asked for permission to open DT, granted, then opened that in DT.

Very strange. I’m seeing no issue with URLs or item links.

And you created a colum with a Link data type, correct?


Does this persist after rebooting the machine?

Unfortunately, yes, sorry about this! Really perplexed.

No worries! There’s always a puzzle to solve. :slight_smile:

@monica.rysavy, try double-clicking on the link (as to edit the field and select the text), then right-click on the text and select open link.

Actually, I tried changing the column type to item link and started seeing the record name in the sheet instead of the URL. If I am in Form View then I can click on the field name and select Reveal in order to get to the file. In Table View, however, it seems that there is no way to activate the link nor to select it and reveal the record. Am I missing something, @BLUEFROG and @cgrunenberg?

Command-clicking should open it in a new tab.

1 Like

@Bernardo_V - Your suggestion to click in the field as if editing and right-clicking did give me a choice that worked (albeit, opening the resource in a new window all together). Thank you!

Is it possible to change a setting so that this opens in the same window?

I’m thinking this will be quite cumbersome otherwise.

1 Like

Note: Command + Clicking (or shift + command + clicking) doesn’t accomplish anything.

Which version of macOS do you use?

Monterey (12.0.1) (reproducible on an M1 iMac and an M1 MBP Max also on same OS, as well as on one version before Monterey on my Air afraid I don’t have access to the exact vs. # at the moment)

Could you please send the sheet to cgrunenberg - at - Thank you!

1 Like