Rebuild database won't complete

Over the last few days I have had trouble getting DT to rebuild a database–the spinning beach ball appears and the program hangs: I’ve let it run for half an hour without success. The progress indicator only gets a certain percentage through the database–and this is not a big database, less than 1700 items of text!

Backup and Optimize go just fine, however. Should I just not try to rebuild a fresh database?

Craig Turner


are you sure thhat rebuilding is not complete, or do you just miss the dialogue? I remember something of that kind from my trials some time ago.


I experimented with rebuilding some months ago, and found that I could not get the rebuilding process to complete. I’ve seen posts by Christian that suggest corrupt RTF files as a possible cause.

Next, I tried exporting my major groups one by one, then creating a new database and importing the material back into DT. That worked, and after finishing I had the correct number of files in my database. :slight_smile:

Remember, however, that if you have a "Files" folder inside your DT database, you must copy it into your new database, if you follow the process in the second paragraph, above. (DT Pro 1.9 and DT PE 1.9 have "package" icons. To look inside the package, select the database file in the Finder, show Info, and delete the ".dtBase" suffix in the filename. After inspection and any file copying, turn the database back into its package form by reversing the name change.)