Registering DEVONthink Pro Office 2.9.16 on Mac OS 10.15.3 Catalina

When I try to register my copy of DEVONthink Pro Office 2.9.16 on Mac OS 10.15.3 Catalina, the Register button is greyed out. Can’t open any databases either.

Strange, software seems compatible with the OS, but the functionality is disabled.

Any reason why this is the case?

Have you got DT3 installed on the same machine? I recently learned that you can’t have the two of them installed together.

Pretty sure I did install DT 3 only after DT 2 did not work. I also had DT 2 and DT 3 on the same machine without a problem. Also deleted DT 3, rebooted and tried DT 2 again — nothing changed. Seems to load, but then I get the Register screen which seems to be broken.

As much as some people at DT are convinced that DT 3 is better, esp. the person you quoted, I really need the three panes view … (I would include a link to a posting I’ve written why, it’s on organizingcreativity dot com titled “DEVONthink 3 — Where the heck is DEVONthink going?” but apparently I cannot include links in my reply.

Looks to me like a forced obsolescence of DT 2 to get people to use DT 3, but I might be (hope! I am) wrong.

Daniel, have you purchased an upgrade license for DT3? If so, you would have to use that license key for DT2 as your old key would have expired.

PS DT2 is compatible with Catalina, only certain functions (e.g. OCR) are not (there was a post from DT about this recently, DT2 uses FineReader v8, which is 32 bit and for which Adobe don’t provide an update to 64 bit; DT3 uses v11 I think; sorry, can’t find the post right now)

I do have a key for DT3, but I just tried it out and it does not work either. The “Register” button remains greyed out. (Plus, would be strange to have to register with a newer version.)

If that is an upgrade key from DT2 you WILL have to use it for DT2, as the old key will expire. There are numerous posts about this in this forum. Obviously, however, at this time that is not your issue, so I have nothing useful to add, sorry (even if I personally would probably try booting in safe mode and seeing if I could enter the key then).

Re compatibility:

Perhaps DT will respond with more help. All the best.

Addendum: I seem to remember reading somewhere that you had to have used the key to activate DT3 once before you could use it (for DT2). That was a while ago, and I won’t promise that I remember that correctly. But if you haven’t already, that might be an idea…

Your software is very out of date. The last version of DEVONthink 2 is 2.11.3.
Please download a new installer from here and replace your current version:

Do not run a third-party uninstaller. If your browser isn’t set to open safe downloaded files, just double-click the ZIP file to decompress it. Then double-click the disk image to open it, and drag and drop the application into the /Applications folder, allowing it to overwrite the old version when you’re prompted.

(There is no danger to your data when you do this. (1) Your data is not stored in the application, and (2) we would not give you instructions that would jeopardize your data.)

After that you should be able to use the DEVONthink 3 license with it.

I just can’t get it right without you :roll_eyes:


2.11.3 is required for proper acceptance of the DEVONthink 3 license… and it’s just good policy to keep up on our updates. :wink:

They both worked side by side for me for a while also, but stopped doing so a few weeks ago. Which was disappointing, as I needed DTPO2 for intense work and was continuing to experiment with DT3 to see if I could find a way of overcoming the enforced workflow changes it introduced. Your organizingcreativity blog post has been mentioned a couple of times in the 3 Pane View thread.