Reminder > notification bug?

Hello,

DevonThink 3.8
Catalina 10.15.7
Forum Search - could not find the answer

When DevonThink triggers a reminder > notification alert, at the scheduled time, I hear the bell sound, but the notification does not appear. On further inspection, if I open the notifications panel in the Mac OS menu bar (3 horizontal bars to the right), I can see the notification. The problem is that it was not displayed. I tried multiple times, including closing and re-opening DevonThink.

I have never had a similar problem in the past, and no other problems with many other notifications from other apps (like gmail) in Mac OS.

thank you

reminder configuration

DevonThink notifications configured as alerts in DevonThink

Notification visible when I open notification panel.
2021-11-06_08-30-00 (1)

The MacOS is very old. Current version is 12.0.1. My hunch is notifications are controlled primarily by the operating system, with DEVONthink just sending in a signal to the operating system. Notifications from DEVONthink work fine for me here (with 12.0.1 and DEVONthink 3.8). Perhaps raise this issue also with Apple Catalina forums?

2 Likes

you are probably right, but happens only with DevonThink, and never happened with DevonThink before ? bug related to an update ?
thank you for your reply

I guess notifications are only shown if DEVONthink isn’t the active app. When it worked in the past DEVONthink was probably not frontmost.

(There were similar threads in the past but can’t find them now.)

3 Likes

What happens if, in DEVONThink, you set the Alarm option (as in your first screen shot) to Display Alert?

Stephen

Hello Stephen,

with alert:

  • from within DevonThink: I see the message box with OK button

  • if in another app: only DevonThink bouncing icon


2021-11-06_11-21-37

I was thinking that would at least provide you with a visible alert.

Stephen

@pete31 is correct on this.

@pete31 @BLUEFROG
thank you but it did not correct the problem. I tried both inside and outside the app

yes, but the bouncing icon is a bit irritating.

It works as expected here when DEVONthink isn’t frontmost…

Screen Shot 2021-11-06 at 09.56.28 AM

Do you have Preferences > General > Enable reminder alarms enabled?

yes. I restarted DevonThink again and it works, as long as I am not in DevonThink, so all is fine and thank you very much @pete31 @Stephen_C @rmschne @BLUEFROG !

You’re welcome :slight_smile: