Removing Black Pop-Up Screen

How do I stop the black pop-up screen from appeaqring over every new web page in Safari? :question:

That’s a glitch involving the “Clip to DEVONthink” Safari (and Firefox) extension, that I can’t replicate on any of my Macs.

The developers are aware of the issue and will resolve it in a future update.

For the present, you may remove the “Clip to DEVONthink” extension from the list of active extensions in Safari’s Preferences.

Unfortunately, I can replicate it every time I open a web page. Thanks for the solution!

Which versions of OS X and Safari are you running? And if you have other extensions installed maybe temporarily disable them and check if the problem still occurs?

OS 10.6.5 and Safari v. 5.0.3. Sorry, but I already deleted the Devon extension, and the problem went away.

Could it be that this has something to do with dynamic GPU switching on MacBook Pros? I have similar effects sometimes with 3D apps.

I have the same problem, altough it does not appear on every website.

The Clip to Devonthink extension is the only one installed.
Also I have an old MBP w just one GPU (2,4GHz, Late 2007).
I am running OSX 10.6.6, Safari 5.0.3